Opened 13 years ago

Closed 13 years ago

#2715 closed defect (fixed)

INDY3: Crash in castle Brunwald (german version).

Reported by: SF/redclaw2k Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 3

Description

convertMessagetoString() throws error: string escape sequence 32 unknown.

Occurs when you enter the second floor of Castle Brunwald and you talk with the soldier (in the right way you can geht pass him).

Ticket imported from: #1514457. Ticket imported from: bugs/2715.

Attachments (1)

indy3.s03 (8.5 KB ) - added by SF/redclaw2k 13 years ago.
Castle Brunwald 2nd floor save

Download all attachments as: .zip

Change History (8)

comment:1 by SF/redclaw2k, 13 years ago

I attached the save game on the position in Castel Brunwald. If you follow the path you will meet the Soldier I mean. Choose answers 2 -> 2 -> 1 then the error will occur.

"Ich führe gerade einen Sicherheitstest durch" is the last answer you can give to the soldier.

by SF/redclaw2k, 13 years ago

Attachment: indy3.s03 added

Castle Brunwald 2nd floor save

comment:2 by fingolfin, 13 years ago

Please state the version of ScummVM you are using and your OS. Thank you.

comment:3 by fingolfin, 13 years ago

Summary: (German PC Version) Game Crahs on dialog in castle BrunwaldINDY3: Crash in castle Brunwald (german version).

comment:4 by SF/redclaw2k, 13 years ago

0.9.0 the newest avaible on the website :)

comment:5 by SF/redclaw2k, 13 years ago

oh I didn't see the OS thing :) I'm using WinXP with service pack 2. NVIDIA Drivers

comment:6 by fingolfin, 13 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:7 by fingolfin, 13 years ago

This bug is caused by a script error in the original game (they encoded the 'sz' letter incorrectly once more). Fixed in Subversion, fix should be contained in tomorrow's daily build.

Note: See TracTickets for help on using tickets.