Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2703 closed defect (fixed)

INDY3 (MAC): Grail diary bug in library

Reported by: SF/glo_kidd Owned by: SF/mthreepwood
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM version: 0.9.0pre june 19 2006
in the library in venice when looking in the grail
diary for which window to find only the window is show
with out the hint for wich tile to break. even when you
find the window that is picured you dont get the hints.
ive included a savegame. to re-create look at window,
and look at grail diary
this is th English/Macintosh/EGA version from the
lucasarts mac pack
i use a win32 snapshot

hope this helps

Ticket imported from: #1509509. Ticket imported from: bugs/2703.

Attachments (4)

indy3.s04 (12.5 KB ) - added by SF/glo_kidd 13 years ago.
Indy3 Mac (Original).png (8.9 KB ) - added by SF/mthreepwood 12 years ago.
Screenshot of Grail Diary (Original Interpreter)
Indy3 Mac (ScummVM).png (7.6 KB ) - added by SF/mthreepwood 12 years ago.
Screenshot of Grail Diary (ScummVM)
Indy3 VGA (ScummVM).png (18.8 KB ) - added by SF/mthreepwood 12 years ago.

Download all attachments as: .zip

Change History (17)

by SF/glo_kidd, 13 years ago

Attachment: indy3.s04 added

comment:1 by SF/glo_kidd, 13 years ago

i have checked on my amiga version and realized that there
is supposed to be a large chunk of text present on the left page
that isnt there when i open my grail diary in the mac version
i also went back to 0.8.1 and checked and this is present
there too

comment:2 by Kirben, 13 years ago

Summary: INDY3: grail diary bug in libraryINDY3 (MAC): Grail diary bug in library

comment:3 by criezy, 13 years ago

I reproduced this bug in the last MacOS X build (January 26, 2007) and with the 0.9.1 version. I also have the English/Macintosh/EGA version.

comment:4 by SF/mthreepwood, 13 years ago

Ok. This bug appears to be more than just a simple script bug. The entire interface is wrong and all text is portrayed incorrectly.

See http://home.comcast.net/~ervind/ij3mac.html

comment:5 by fingolfin, 13 years ago

Priority: normallow

comment:6 by fingolfin, 13 years ago

This "bug" is caused by the fact that we do not fully support the mac version of indy3, which has some special changes in its interface and text code.

Lowering priority of this (implenting this feature would be rather difficult, yet gains us relatively little given how rare the mac version of indy3 is compared to other indy3 versions).

comment:7 by SF/mthreepwood, 12 years ago

See here:

http://sourceforge.net/tracker/index.php?func=detail&aid=1851568&group_id=37116&atid=418822

comment:8 by fingolfin, 12 years ago

Should be fixed by patch #1509509, thanks to mthreepwood. At least he says so, please double check :)

comment:9 by fingolfin, 12 years ago

Owner: set to SF/mthreepwood
Resolution: fixed
Status: newclosed

comment:10 by criezy, 12 years ago

As I wrote in the patch tracker I confirm the patch does correct the issue for me as well.
My thanks to mthreepwood for his work on solving this issue.

by SF/mthreepwood, 12 years ago

Attachment: Indy3 Mac (Original).png added

Screenshot of Grail Diary (Original Interpreter)

comment:11 by SF/mthreepwood, 12 years ago

criezy: Well, it fixes the issue, but the text is still not right. It seems the original used a different font. From where, I do not know. Attaching a screenshot of the original.
File Added: Indy3 Mac (Original).png

by SF/mthreepwood, 12 years ago

Attachment: Indy3 Mac (ScummVM).png added

Screenshot of Grail Diary (ScummVM)

comment:12 by SF/mthreepwood, 12 years ago

Attaching what it looks like in ScummVM. (Oh, and ignore that the image from the original interpreter is cut off a bit. :P)
File Added: Indy3 Mac (ScummVM).png

by SF/mthreepwood, 12 years ago

Attachment: Indy3 VGA (ScummVM).png added

comment:13 by SF/mthreepwood, 12 years ago

One more. This is of the VGA DOS version (just put here for comparison).
File Added: Indy3 VGA (ScummVM).png

Note: See TracTickets for help on using tickets.