Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2694 closed defect (invalid)

FT: Wrong background colours

Reported by: SF/pochini Owned by: eriktorbjorn
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Background has wrong palette. All the rest (characters
and other moving items, action selector, inventory,
animations, ...) is fine.

FT-italian, gcc 3.4.4, powerpc, libsdl-1.2.8, scummvm-
20060618, scummvm-0.8.2, X-org.

Ticket imported from: #1508125. Ticket imported from: bugs/2694.

Change History (13)

comment:1 by Kirben, 13 years ago

Summary: Wrong background coloursFT: Wrong background colours

comment:2 by sev-, 13 years ago

Please test whether you can reproduce this bug
with the latest daily SVN build which you can find
at the bottom of our downloads page:
<http://www.scummvm.org/downloads.php>.

comment:3 by sev-, 13 years ago

Status: newpending

comment:4 by SF/pochini, 13 years ago

Yes, same problem with 20060620. The only related change
from 20060618 to 20060620 is in ScummEngine::redrawBGAreas()
which is not the cause of the problem AFAICS.

comment:5 by SF/pochini, 13 years ago

Status: pendingnew

comment:6 by eriktorbjorn, 13 years ago

It's far-fetched, I know, but you haven't accidentally
changed the "Platform" setting to Amiga, have you? That
would cause problems similar to the ones you describe.

comment:7 by SF/pochini, 13 years ago

*grumble* Yes, it was Amiga. I didn't want to change the
default settings at all.
Sorry for the noise...

comment:8 by SF/pochini, 13 years ago

Status: newclosed

comment:9 by eriktorbjorn, 13 years ago

Did ScummVM detect the game as an Amiga version? That in
itself would be a bug -- as far as I know, there wasn't any
Amiga version of that game.

comment:10 by eriktorbjorn, 13 years ago

Resolution: invalid

comment:11 by eriktorbjorn, 13 years ago

Owner: set to eriktorbjorn

comment:12 by SF/pochini, 13 years ago

No, I thought I left the default setting selected, but I set
Amiga instead. ScummVM does not change the settings its own.
I don't know if it is supposed to refuse a wrong setting,
though.

comment:13 by SF/pochini, 13 years ago

Priority: normallow
Note: See TracTickets for help on using tickets.