Opened 13 years ago

Closed 13 years ago

#2688 closed defect (fixed)

BASS: Odd press sound at beginning

Reported by: SF/adventureguy Owned by: eriktorbjorn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Hello!
I tested the English Talkie version of Beneath a Steel
Sky on the 0.9.0pre built of 17th June 2006 on Windows
and I wondered that the sound of the press in the first
room sounds a bit odd, like the gunshot in the Windows
MIDI system. When I tested it with the stable 0.8.2
version, it sounded a bit different. Is this related
with using the Windows MIDI System you can choose in
the menu? I selectet just default.

Ticket imported from: #1507757. Ticket imported from: bugs/2688.

Attachments (1)

samplerate.diff (1.9 KB ) - added by eriktorbjorn 13 years ago.
Patch against current SVN

Download all attachments as: .zip

Change History (6)

comment:1 by sev-, 13 years ago

Summary: Press sound at beginningBASS: Odd press sound at beginning

comment:2 by eriktorbjorn, 13 years ago

No, it has nothing to do with MIDI -- the sound is
digitized. But for some reason, that function now always
assumes the sound is sampled at 11025 Hz. Before, it looked
the sample rate up in the game data file.

Seems like a regression to me.

comment:3 by eriktorbjorn, 13 years ago

Owner: set to lavosspawn

comment:4 by eriktorbjorn, 13 years ago

Looking some more, it appears that the behaviour was changed
as part of a much larger cleanup. I've attached a patch to
revert that part of it to the old behaviour (I hope I got it
right), but I'm not going to apply it at this time, since I
don't yet know why the change was made in the first place.

Judging by how the game plays in DOSbox, the old behaviour
was the right one.

by eriktorbjorn, 13 years ago

Attachment: samplerate.diff added

Patch against current SVN

comment:5 by Kirben, 13 years ago

Owner: changed from lavosspawn to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.