Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2682 closed defect (fixed)

INDY3 (VGA): Guards in Zeppelin can float...

Reported by: SF/bramvandijk Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

When I was going throught the zeppelin to the bi-plane,
two guards seemed to walk over paths that were not there,
I used scummvm-23140 (june 16th) on linux

How to reporoduce:
-Load savegame,
-walk towards the stairs,
-look at guard

Ticket imported from: #1507133. Ticket imported from: bugs/2682.

Attachments (2)

indy3.s14 (11.8 KB ) - added by SF/bramvandijk 13 years ago.
Savegame with glitch
indy3.s11 (15.3 KB ) - added by SF/bramvandijk 13 years ago.
Earlier savegame

Download all attachments as: .zip

Change History (8)

by SF/bramvandijk, 13 years ago

Attachment: indy3.s14 added

Savegame with glitch

comment:1 by lordhoto, 13 years ago

I didn't try this savegame but I can confirm that the guards
are sometimes able to walk in places there they shouldn't be
able to (same with Indy, happens very rarely though).

comment:2 by fingolfin, 13 years ago

The walk code fixes I commited today also affect walking in V3 games, in particular issues like the one describe here.

Unfortunately, this savegame can't be used to test whether these changes helped to resolve the issue or not, because in there one guard is already in a buggy state (outside of any box), so no matter what we change, he will always walk incorrectly. Maybe somebody has a savegame a bit earlier and can use that to test whether this bug still occurs...

by SF/bramvandijk, 13 years ago

Attachment: indy3.s11 added

Earlier savegame

comment:3 by SF/bramvandijk, 13 years ago

Adding another savegame, just walk up the ladder and walk around in the maze. I tried for 2 minutes and couldn't see any guard walking wrong, but it took much longer in the first place, so I'll try a bit more when I have more time.
File Added: indy3.s11

comment:4 by SF/bramvandijk, 13 years ago

I just played through the whole zeppelin scene again, and this time each guard stayed on the path. So it seems like this bug is fixed.

comment:5 by fingolfin, 13 years ago

Great :). Thanks for the testing!

comment:6 by fingolfin, 13 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.