Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2675 closed defect (fixed)

PUTTTIME: Weird Mouth Movement

Reported by: SF/mthreepwood Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt Travels Through Time

Description

This glitch only happens in Putt-Putt Travels Through
Time. I used the Windows/English with Win32 0.9.0pre
from 6/14/06.

When any character is talking, it looks like the
character has two mouths. I attached a picture to
show you what it looks like. You don't need a saved
game, because it happens throughout the game.

Ticket imported from: #1506002. Ticket imported from: bugs/2675.

Attachments (2)

Time Error.JPG (69.4 KB ) - added by SF/mthreepwood 13 years ago.
Screenshot of Error
PuttTime.s01 (44.7 KB ) - added by SF/mthreepwood 13 years ago.
Saved Game

Download all attachments as: .zip

Change History (11)

by SF/mthreepwood, 13 years ago

Attachment: Time Error.JPG added

Screenshot of Error

comment:1 by sev-, 13 years ago

Summary: Weird Mouth Movement in putttimePUTTTIME: Weird Mouth Movement

comment:2 by sev-, 13 years ago

Please, attach a save game or tell us md5 of HE0 file. If
you don't know what md5 is, simply attach any save game.

Also does it happen in every case?

comment:3 by SF/mthreepwood, 13 years ago

It happens to all the characters.

by SF/mthreepwood, 13 years ago

Attachment: PuttTime.s01 added

Saved Game

comment:4 by sev-, 13 years ago

It is HE80 version of the game. MD5 is
63fdcdc95cdeea00060883aed38e5504

The bug does not happen in HE99 and HE100 versions. Also I
don't see it in HE90 demos. And HE80 freddi3 game renders
characters without the glitch

Kirben, do you have HE80 version?

comment:5 by sev-, 13 years ago

Owner: set to Kirben

comment:6 by Kirben, 13 years ago

No, I only have the HE99 and HE100 versions of this game.

comment:7 by Kirben, 13 years ago

Resolution: fixed
Status: newclosed

comment:8 by Kirben, 13 years ago

The cause of the glitches, was the condMaskCode changed in
setUserCondition & setTalkCondition.

So I have added another HE version (85), since the
condMaskCode changed in a few games (putttime and socks)
before HE 90.

comment:9 by Kirben, 13 years ago

Component: Engine: SCUMM
Game: Putt-Putt Travels Through Time
Note: See TracTickets for help on using tickets.