Opened 13 years ago

Closed 13 years ago

Last modified 13 months ago

#2649 closed defect (invalid)

GUI: Strange keyboard behaviour

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Current ScummVM SVN version

This may be partly an SDL problem (Debian 1.2.9)
packages, but here's what's happening to me. In the
GUI, I try to enter a ! in an input field.

Sometimes, I only get a key down event for the shift
key, not for the ! key. I have no idea why.

Assuming I do get key down events for both keys, I
first get one for the Shift key (keycode 304) and one
for the ! key (keycode 33). So far, so good.

If I release the ! key before the Shift key, I get a
key up events for keycodes 33 and 304, in that order.
That's fine.

If I release the Shift key before the ! key, I only get
a key up event for the Shift key, keycode 304.

Since the GUI thinks the ! is still held down, it will
begin repeating.

Ticket imported from: #1498735. Ticket imported from: bugs/2649.

Change History (6)

comment:1 by eriktorbjorn, 13 years ago

Owner: set to fingolfin

comment:2 by eriktorbjorn, 13 years ago

I can no longer reproduce this. Possibly because I updated
to the SDL 1.2.10 packages that just entered Debian
unstable. I see the X11 input driver was changed, among
other things.

comment:3 by eriktorbjorn, 13 years ago

Resolution: invalid
Status: newclosed

comment:4 by eriktorbjorn, 13 years ago

Owner: changed from fingolfin to eriktorbjorn

comment:5 by eriktorbjorn, 13 years ago

This is probably the explanation (from the Debian changelog):

* debian/patches/005_x11_keysym_fix.diff:
+ Disabled this patch because it breaks numerous
programs that assume,
quite correctly, that a keysym actually represents the
physical key
being pressed (Closes: #347709, #358870, #358976,
#360872).

comment:6 by digitall, 13 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.