Opened 18 years ago

Closed 17 years ago

Last modified 17 years ago

#264 closed defect (fixed)

SAM: iMuse transition/lockup problems

Reported by: SF/jbergstrom Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM 0.2.0
English CD-Rom talkie
Win32

There are several errors in the iMuse behavior in this
game. Here are some that I have spotted:

1. At the Ball of Twine the normal theme plays for a
while, then is cut off and the cable car theme will
play instead.

2. At the Carnival, in the Kushman brothers tent, the
music is played in percussion instruments only.

3. In the Snuckeys there is a strange perc. transition
before the theme plays.

4. The game produces an immense amount of "IMuse
Internal::findTag failed finding sound x" errors.

5. Music won't loop.

6. Sometimes instruments drop out.

(There's no savegame since these are quite general.)

Ticket imported from: #556493. Ticket imported from: bugs/264.

Change History (12)

comment:1 by SF/ender, 18 years ago

Sam and Max uses a different iMUSE engine to the one
implmemented in ScummVM currently, which causes all these
problems. We have made several hacks to allow Sam and Max
to sound 'reasononable', but for perfection the iMUSE
driver for Sam and Max will need to be disassembled,
understood, and recoded.

This will take a lot of work, so we don't expect this bug
to be fixed in any short period of time.

Lowering priority to 'trivial', as this does not really
affect gameplay.

comment:2 by SF/ender, 18 years ago

Priority: normallow
Summary: iMuse transition problemsSam and Max iMuse transition problems

comment:3 by SF/ender, 17 years ago

iMUSE implementation bugs are also the cause of bug
554619. See bug 555277 for technical details.

comment:4 by SF/ender, 17 years ago

Summary: Sam and Max iMuse transition problemsSam and Max iMuse transition/lockup problems

comment:5 by fingolfin, 17 years ago

Summary: Sam and Max iMuse transition/lockup problemsSAM: iMuse transition/lockup problems

comment:6 by SF/jamieson630, 17 years ago

Jbergstrom, a number of recent Sam & Max iMuse upgrades
have corrected a variety of symptoms such as the ones you
describe, in particular #1, #5 and #6. Try playing through with
the latest CVS build and identify how many instances of
buggy behavior still remain.

Specific description of location and unexpected behavior is
most useful -- we are pinpointing these problems one by one
now.

Also, ref. 622544 for one iMuse issue we're already
investigating. If you see any do_command code 12 warnings
other than the ones referenced there, add them to the lis.

Ender, if you're going to leave this open, want me to pick it
up?

comment:7 by SF/ender, 17 years ago

Owner: set to SF/jamieson630

comment:8 by SF/ender, 17 years ago

Yeah, please do :)

Your the one with enough knowledge of MIDI to know why things like
percussion problems are happening.

Assigning to jamieson630

comment:9 by SF/jamieson630, 17 years ago

Just a quick update on the status of the 6 problems
mentioned here:

1. Ball of Twine music has been running smoothly for a while
now.

2. Problems with things being played all in percussion should
be taken care of by the new setup code for Parts. A part is
now only tagged as percussion if it's on the percussion
channel or (in the case of ROL tracks) is explicitly designated
a percussion track by a SysEx message.

3. I never encountered this, but probably the same as #2.
Jbergstrom, can you verify this with the latest CVS build?

4. I think this is still outstanding, but I haven't looked into
what's going on. It doesn't seem to affect anything, unless it
has something to do with music starting when it's supposed
to wait for a transition riff (e.g. in several places in the
carnival). Hmm, this is an interesting hypothesis....

5. Most looping and transition problems are taken care of,
except in cases where monitor scripts don't seem to start
(e.g. the script that handles the transition from the Gator Golf
intro to the main block of music, and the script that handles
the transition from the outdoor Bumpusville music to the
indoor music).

6. Now that General MIDI has been expanded to support the
full 16 channels (instead of the 10-channel Extended MIDI
configuration), there should be no lost instruments. (The Sam
& Max opening cutscene music sounds a whole lot better in
General MIDI now, BTW.)

comment:10 by SF/jbergstrom, 17 years ago

Oh yes, most of these have been fine for a quite a while now,
including #3. I don't also seem to get #4 any more.

comment:11 by SF/jamieson630, 17 years ago

Great, nothing of substantial concern left then. :) Closing.

comment:12 by SF/jamieson630, 17 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.