Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#2637 closed defect (fixed)

KYRA1: Subtitles glitch during "Speech of the Land"

Reported by: eriktorbjorn Owned by: lordhoto
Priority: low Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

Current SVN snapshot
English talkie version

During the "Speech of the Land", at the point where
Brandon says "What!?" followed by "Why me?" these two
subtitles are partially erased before they are
completely removed. (This happens in the first room of
the game, so I'm not going to attach a savegame.)

It appears to be because the game redraws the face on
the wall. I don't know why it does this, because it
redraws the current frame. In other words, I can work
around the glitch by adding a test to
WSAMovieV1::displayFrame() to check if frameNum ==
_currentFrame. But that probably breaks other things.

Ticket imported from: #1497437. Ticket imported from: bugs/2637.

Attachments (2)

av_sync.patch (10.5 KB ) - added by lordhoto 12 years ago.
patch against SVN, relying on patch #1970427
av_sync_v2.patch (9.6 KB ) - added by lordhoto 12 years ago.
patch against SVN, relaying on audiostream_v2.patch from #1970427

Download all attachments as: .zip

Change History (20)

comment:1 by eriktorbjorn, 14 years ago

Owner: set to lordhoto

comment:2 by eriktorbjorn, 14 years ago

As far as I can tell, these two subtitles are drawn at
exactly the same spot as in the original, so wrong
positioning isn't the cause of the problem.

comment:3 by eriktorbjorn, 14 years ago

Owner: changed from lordhoto to vinterstum

comment:4 by sev-, 12 years ago

What is the status of this item?

comment:5 by lordhoto, 12 years ago

Priority: normallow

comment:6 by lordhoto, 12 years ago

Very minor glitch, thus I will lower priority.

As for the problem: I did not find anything what could be wrong when comparing to disassembly, guess it will take a closer look and that is not worth the effort for this bug IMHO.

comment:7 by eriktorbjorn, 12 years ago

I agree that it's a minor glitch. I just want to clarify that it still happens with the current SVN snapshot.

comment:8 by bluegr, 12 years ago

As a workaround to this, I think that eriktorbjorn's workaround could simply be applied to that scene only - it shouldn't break anything. Your thoughts?

comment:9 by lordhoto, 12 years ago

Well that could be done, still I don't like to work around that in WSAMovieV1::displayFrame, I would rather apply that to the function calling it in script_v1.cpp (whatever of the WSA specific opcodes that would be), or at best fix the real reason behind it.

comment:10 by fingolfin, 12 years ago

Could be a matter of the order in which you draw the video vs. the subtitles? Resp. maybe the subtitles simply are redrawn automatically every frame if a video plays? Or maybe the original video rendered did not overdraw subtitles (e.g. because the subtitles use a "magic color" making it possible to mask them)?

comment:11 by lordhoto, 12 years ago

I checked a bit through CD disasm, but I can't see any places there text drawing is called for the opcodes used by this specific scene. At least the initial drawing order should be correct, I don't know anything of a 'magic color' either, and we should not forget it works everywhere else when text is drawn too. Maybe there is some place where the subtitles are drawn again, but I didn't find that yet.

by lordhoto, 12 years ago

Attachment: av_sync.patch added

patch against SVN, relying on patch #1970427

comment:12 by lordhoto, 12 years ago

Owner: changed from vinterstum to lordhoto

comment:13 by lordhoto, 12 years ago

File Added: av_sync.patch

comment:14 by lordhoto, 12 years ago

Oops forget the description, I added a patch fixing this issue correctly (along with some other audio/video glitches), the patch relies on a patch from the patch tracker though (#1970427 "Fixed Length Audio Stream class").

by lordhoto, 12 years ago

Attachment: av_sync_v2.patch added

patch against SVN, relaying on audiostream_v2.patch from #1970427

comment:15 by lordhoto, 12 years ago

Updated patch here for new patch at patch tracker item #1970427.
File Added: av_sync_v2.patch

comment:16 by lordhoto, 12 years ago

Should be fixed in current SVN (at least without compressed audio files), I'll leave it open till it's also fixed for compressed audio files.

comment:17 by lordhoto, 12 years ago

For compressed audio files it is now fixed too.

comment:18 by lordhoto, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.