Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2615 closed defect (fixed)

KYRA1: Weird mouse pointer behaviour

Reported by: jvprat Owned by: eriktorbjorn
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

When running the floppy spanish version of kyrandia (I don't know if it also happens in other versions), the mouse pointer behaves a little strange. It seems like sometimes it doesn't draw correctly. I attach a screenshot of one time it didn't paint well even when stopping the movement. It happens both with normal cursor and when I pick up an object. Each time it seems to be cut differently.

Moreover, when an actor is talking (text written on the screen), it seems like the mouse pointer gets lower refresh rate, and you see the same effect described above but now happening more slowly. Both effects combined give a very strange feeling.

Let me know if you need more information (that I can deterministically get).

Thanks for your work!

Ticket imported from: #1494934. Ticket imported from: bugs/2615.

Attachments (1)

wrong_cursor.png (52.5 KB ) - added by jvprat 14 years ago.

Download all attachments as: .zip

Change History (8)

by jvprat, 14 years ago

Attachment: wrong_cursor.png added

comment:1 by lordhoto, 14 years ago

I can't reproduce it over here, I fixed some problems with walking though, so maybe you could check if it's gone now?

comment:2 by lordhoto, 14 years ago

Owner: set to lordhoto

comment:3 by eriktorbjorn, 14 years ago

The broken cursors (happen for me at least sometimes at the very moment a cursor changes from one shape to another) is probably a bug in the SDL backend. The cursor handling has been going through some changes lately, and might not have fully recovered yet.

That the cursor movement gets a bit jerkier while a character is talking is probably because waitForChatToFinish() doesn't cause the screen to be updated frequently enough.

comment:4 by jvprat, 14 years ago

I've just recompiled it from the svn and it seems like the cursor is always drawn well now (I'll see if it's also gone in the daily snapshots). Now the only issue is the slow repainting when an actor is talking.

comment:5 by eriktorbjorn, 14 years ago

Should be fixed in SVN now.

comment:6 by eriktorbjorn, 14 years ago

Owner: changed from lordhoto to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:7 by jvprat, 14 years ago

It works smooth now, but when the actor has finished the talking animation and while there's no other movement in the scene, the cursor is shown, even in cutscenes (when I think it should mantain hidden if it was while talking). Thanks for your work!

Note: See TracTickets for help on using tickets.