Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2605 closed defect (fixed)

MANIAC/ZAK:Sentence Line only displays first char

Reported by: SF/jduteau Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

In the latest SVN build, the Sentence Line only
displays the first character. I tried 0.82 and it's
fine there, so something in the latest build broke it.

Ticket imported from: #1488189. Ticket imported from: bugs/2605.

Change History (4)

comment:1 by Kirben, 13 years ago

Owner: set to fingolfin
Summary: Sentence Line only displays first char in latest SVN buildMANIAC/ZAK:Sentence Line only displays first char

comment:2 by Kirben, 13 years ago

The problem effects Maniac Mansion and Zak McKracken games,
when using current ScummVM SVN.

The problem was caused by changes made to
engines/scumm/charset.cpp in Rrevision: 22374, assigning to
fingolfin who made that change.

comment:3 by eriktorbjorn, 13 years ago

That change was apparently made to ensure that the string
didn't get too long for the screen. But we never specified
the right edge for the sentence line, so it was assumed to be 0.

Should be fixed in SVN now.

comment:4 by eriktorbjorn, 13 years ago

Owner: changed from fingolfin to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.