Opened 14 years ago

Closed 14 years ago

Last modified 11 months ago

#2566 closed defect (fixed)

ALL: Config file messed up with latest SVN

Reported by: SF/kaminari Owned by: fingolfin
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

ScummVM SVN 0.9 for Win32 (1746K exe file, last update:
April 15, 2006, 6:32 pm).

I'm running on Windows XP SP2. Since a couple of SVN
builds, I'm having two problems with the scummvm.ini
config file:

1. music_driver is always set to "true" in the config
file, whatever the actual driver I choose in the
Launcher. I don't know what "true" means in that case,
but it looks like an incorrect value to me. Ingame,
games that rely on Midi or FM always fall back to FM
(Sam and Max for example).

2. all entries are systematically unsorted after
running a game with the SVN build.

o Config file before launching SVN:

[scummvm]
aspect_ratio=false
autosave_period=0
enable_gs=true
extrapath=D:\ScummVM\!extra\
fullscreen=true
gfx_mode=HQ2x
gui_theme=default
lastselectedgame=sam
multi_midi=true
music_driver=auto
music_volume=192
native_mt32=true
output_rate=44100
savepath=D:\ScummVM\!save\
sfx_volume=192
speech_volume=192
subtitles=true
themepath=D:\ScummVM\!theme\
versioninfo=0.9.0svn

[sam]
aspect_ratio=false
description=Sam and Max Hit the Road
enable_gs=true
fullscreen=true
gameid=samnmax
language=en
multi_midi=true
music_driver=windows
music_volume=192
native_mt32=true
path=D:\ScummVM\sam\
platform=pc
sfx_volume=192
speech_mute=false
speech_volume=192
subtitles=true

o Config file after launching SVN and running Sam:

[scummvm]
gfx_mode=HQ2x
music_volume=192
speech_volume=192
aspect_ratio=false
extrapath=D:\ScummVM\!extra\
music_driver=true
lastselectedgame=sam
native_mt32=true
gui_theme=default
subtitles=true
themepath=D:\ScummVM\!theme\
fullscreen=true
sfx_volume=192
autosave_period=0
enable_gs=true
multi_midi=true
output_rate=44100
versioninfo=true
savepath=D:\ScummVM\!save\

[sam]
description=Sam and Max Hit the Road
music_volume=192
speech_volume=192
path=D:\ScummVM\sam\
aspect_ratio=false
music_driver=true
native_mt32=true
subtitles=true
platform=pc
gameid=samnmax
language=en
fullscreen=true
sfx_volume=192
speech_mute=false
enable_gs=true
multi_midi=true

(Also note the versioninfo=true field.)

Ticket imported from: #1471383. Ticket imported from: bugs/2566.

Change History (5)

comment:1 by fingolfin, 14 years ago

The bug you reported (music_driver etc. being set to true) is fixed now, thanks
for the report.

As for the key/value pairs not being sorted: That is by design; that they were
sorted before was purly coincidence. If you think that they key/value pairs
should be sorted, feel free to submit a feature request and we'll consider it for
the future... though it might help to add some reasons why you think it's worth
the effort :-).

comment:2 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Summary: Config file messed up with latest SVNALL: Config file messed up with latest SVN

comment:3 by SF/kaminari, 14 years ago

Thanks for fixing it so quickly.

I just thought the unsorted thing was a side-effect of the
"true" bug, which is why I felt necessary to report it. No
particular reason for having alphabetically-sorted values,
except that it makes them easier to find when you're used to
edit them manually. But it's no big deal, really.

comment:4 by fingolfin, 14 years ago

Just to explain:
The "sorting issue" is actually a bit older, and is a result of us switching from
Map to HashMap. Map kept everything in a binary search tree, which means it
was automatically sorted. OTOH, HashMap now keeps everything in a
seemingly random order.
We could write the key/value pairs sorted, but then we'll have to explicitly
sort them. Certainly possible, but requires extra code... Wouldn't be too
difficult to implement, either. But I shy away from adding this (which could
introduce new bugs).

comment:5 by digitall, 11 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.