Opened 13 years ago

Closed 13 years ago

#2541 closed defect

FOA: Crash when using ribcage with sandwich/bratwurst

Reported by: SF/dangerouswhelp Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

I'm using ScummVM version 0.8.2.
The game Indiana Jones and the Fate of Atlantis crashes
to desktop whenever I use the bratwurst or the sandwich
with the ribcage in Atlantis. I'll attach the relevant
savegame. To reproduce the crash, you just need to USE
the BRATWURST *or* the SANDWICH with the RIBCAGE.
I'm using the ENGLISH version of TALKIE version of Fate
of Atlantis, running on the WIN32 version of ScummVM 0.8.2.

Ticket imported from: #1453668. Ticket imported from: bugs/2541.

Attachments (1)

atlantis.s02 (33.1 KB) - added by SF/dangerouswhelp 13 years ago.
savegame for reproduction of the bug.

Download all attachments as: .zip

Change History (12)

Changed 13 years ago by SF/dangerouswhelp

Attachment: atlantis.s02 added

savegame for reproduction of the bug.

comment:1 Changed 13 years ago by fingolfin

Like the infamous "Stamp crash" in DOTT, this bug has been reported several
times in past, but we've never been able to reproduce it.

See also bug #666253, #852482, #1165825. (and to see ten or so bug reporst
on the stamp crash, use the search feature :-).

comment:2 Changed 13 years ago by fingolfin

Summary: FoA: Crash when using ribcage with sandwich/bratwurstFOA: Crash when using ribcage with sandwich/bratwurst

comment:3 Changed 13 years ago by fingolfin

Oh and just to make this clear: I still can't reproduce it, neither with 0.8.2, nor
with latest CVS. Under Mac OS X. Just like I never was able to reproduce it in the
past <sigh>.

Maybe somebody can run this under valgrind to see if any odd memory access
happens. Kirben?

comment:4 Changed 13 years ago by fingolfin

Owner: set to Kirben

comment:5 Changed 13 years ago by Kirben

No problems are reported under Valgrind. when combining
those items.

comment:6 Changed 13 years ago by Kirben

Owner: Kirben deleted

comment:7 Changed 13 years ago by fingolfin

Status: newpending

comment:8 Changed 13 years ago by fingolfin

dangerouswhelp, can you reliably reproduce the problem? I.e. does it crash
every time? Sometimes?

comment:9 Changed 13 years ago by SF/zealot2000

I have exactly the same problem with the english floppy
version of FOA. OS is XP SP2. This problem occurs using
ScummVM 0.8.2. I've downgraded to 0.8.0 (Just installed over
0.8.2) and everything works fine.

comment:10 Changed 13 years ago by SF/sf-robot

Status: pendingclosed

comment:11 Changed 13 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.