Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2516 closed defect (fixed)

HE PAJAMA 3: Stomach room glitches

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Pajama Sam 3

Description

ScummVM 0.9.0svn (Mar 2 2006 09:15:03)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The room right beyond the Bloodurbs(sp?) sign, where
one can get the "Free Etiquette lesson" vouchers, is
the room where those cans dancing the "hop".
This room is completely crippled (gfx), there are
stripes in the background animation and around the
cans. Dancing and jumping cans "recover" those
glitches when they reach them, though.

Other than that and the pumpkin head glitch, i did
not find any more glitches in the game.

Ticket imported from: #1442099. Ticket imported from: bugs/2516.

Attachments (1)

Gfx_Glitch.jpg (78.8 KB ) - added by SF/*anonymous 14 years ago.
Grab that shows the glitch

Download all attachments as: .zip

Change History (14)

comment:1 by Kirben, 14 years ago

I can't reproduce these glitches, the Stomach room is fine
when using ScummVM under Windows XP Home Edition.

Are you still using an Amiga system? maybe it could be an
endian issue in source code.

comment:2 by (none), 14 years ago

Most surely it is, i cannot provide a screenshot of how it
looks like but it seems to be only a problem in the
foreground, the background is fine, will see if i can get
some Amiga users to do further testing.

Thanks anyway

by SF/*anonymous, 14 years ago

Attachment: Gfx_Glitch.jpg added

Grab that shows the glitch

comment:3 by Kirben, 14 years ago

Summary: Pajama 3: Bloodurbs (sp?) Party room crippledPajama 3: Stomach room glitches (Amiga)

comment:4 by fingolfin, 14 years ago

Summary: Pajama 3: Stomach room glitches (Amiga)HE PAJAMA 3: Stomach room glitches (Amiga)

comment:5 by Kirben, 14 years ago

I fixed some endian issues in akos costume code (Which is
used by this game), so please try the next daily snapshot
of ScummVM.

comment:6 by (none), 14 years ago

Thanks for the update,
but the glitch is still there with todays snapshot.

comment:7 by Kirben, 13 years ago

Recently reported to occur on a PC too, see bug #1506698.

Strange, as I'm still unable to reproduce the issue myself.

comment:8 by Kirben, 13 years ago

This problem only occurs, when subtitles are disabled.

The stripes in the background are fixed, but the area
behind the cans still isn't updated correctly.

comment:9 by (none), 13 years ago

Confirmed for the AmigaOS4 build

Great work so far, thanks

comment:10 by Kirben, 13 years ago

Summary: HE PAJAMA 3: Stomach room glitches (Amiga)HE PAJAMA 3: Stomach room glitches

comment:11 by Kirben, 13 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:12 by (none), 13 years ago

err..fixed?

do i have to open a new item for the part behind the cans?

comment:13 by Kirben, 13 years ago

Yes, completely fixed, just wait for the next ScummVM SVN
snapshot.

Note: See TracTickets for help on using tickets.