Opened 13 years ago

Closed 12 years ago

#2515 closed defect (duplicate)

HE SPYFOX 2: Lift glitch when reloading

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Spy Fox 2

Description

ScummVM 0.9.0svn (Mar 2 2006 09:15:03)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Walk to the Binoculars at the fair and try to look through them,
i get following output from debug:

(58:2070:0x30BD): Invalid array access (1,1,4,7) limit (0,587202560,16777216,268435456)
(58:2070:0x30BD): Invalid array access (1,1,4,7) limit (0,587202560,16777216,268435456)!

description=Spyfox 2: Some Assembly Required (English (US))
language=en

AmigaOS4 compile

Can't provide a save game, SF still won't let me upload one

Ticket imported from: #1441950. Ticket imported from: bugs/2515.

Change History (19)

comment:1 Changed 13 years ago by (none)

Summary: Crash at BinocularsSpyfox 2: Crash at Binoculars

comment:2 Changed 13 years ago by (none)

There is also a little gfx glitch when loading a saved position on top of the lookout.

If you walk (after loading) right back into the lift the doors are closed
and Spyfox will walk THROUGH them instead of opening it (automatically methinks)
They will open and close if he's in though

comment:3 Changed 13 years ago by fingolfin

You *should* be able to upload a save game, unless your browser is broken. Just
make sure to activate the "Check to Upload and Attach a File" checkbox. And
sometimes, uploading files when you submit a tracker item, but so far it always
worked for me to attach a file to an existing tracker item...

Also, please keep in mind: one bug report for one issue.

comment:4 Changed 13 years ago by (none)

Truly sorry, i get the error everytime i try:

Error

Uploaded file must be >20 and <256000 bytes.

comment:5 Changed 13 years ago by fingolfin

Uh... then the file is too big and you need to compress it? :-).

comment:6 Changed 13 years ago by (none)

Gosh ???

Those Aliens made me dumb again, these are BYTES! :-(

But i cannot crunch the file to a smaller size than approx.
400Bytes, so still no go :-(

comment:7 Changed 13 years ago by Kirben

If the issues is always reproducable, please send the saved
game to kirben@users.sourceforge.net

comment:8 Changed 13 years ago by Kirben

Summary: Spyfox 2: Crash at BinocularsSpyfox 2: Crash at Binoculars (Amiga)

comment:9 Changed 13 years ago by Kirben

I got the saved game but I can't reproduce the issue with
ScummVM under Windows XP Home Edition. I suspect this is
another endian issue, in the copyArray() functions.

comment:10 Changed 13 years ago by Kirben

The problem should hopefully be fixed now, try the next
daily snapshot of ScummVM.

comment:11 Changed 13 years ago by (none)

New snapshot fixed the crash

(Still there is this gfx glitch with the closed lift doors,
should i file another report?)

Thanks a lot

comment:12 Changed 13 years ago by Kirben

No, I will just update the bug title this time.

comment:13 Changed 13 years ago by Kirben

Summary: Spyfox 2: Crash at Binoculars (Amiga)Spyfox 2: Lift glitch when reloading

comment:14 Changed 13 years ago by fingolfin

Summary: Spyfox 2: Lift glitch when reloadingHE SPYFOX 2: Lift glitch when reloading

comment:15 Changed 12 years ago by fingolfin

So this sounds as if part of the actor/room state is not properly saved, doesn't it?

comment:16 Changed 12 years ago by sev-

What is the status of this item?

comment:17 Changed 12 years ago by sev-

Owner: set to Kirben

comment:18 Changed 12 years ago by Kirben

Resolution: duplicate
Status: newclosed

comment:19 Changed 12 years ago by Kirben

Closing as duplicate, any glitches after reloading saved games, are combined in bug report #1726909 now.

Note: See TracTickets for help on using tickets.