Opened 14 years ago

Closed 14 years ago

Last modified 17 months ago

#2504 closed defect

configure fixes for Solaris compatibility

Reported by: SF/lblume Owned by: sev-
Priority: low Component: Port: Solaris
Keywords: Cc:
Game:

Description

There are two trivial bugs that prevent configure to work out on the bugs on Solaris: - use of "export PATH", unsupported by Solaris' old /bin/sh - parameter of tail, which seems to be GNU-specific

I corrected the first, and changed the tail parameter to something which is OK by XPG4, so must be supported on any Unix (tested on Solaris and Ubuntu).

See the small attached patch, done on today's CVS.

Ticket imported from: #1436165. Ticket imported from: bugs/2504.

Attachments (2)

scummvm_configure.patch (844 bytes ) - added by SF/lblume 14 years ago.
/bin/sh, tail & config.guess Solaris compatibility
scummvm_configure_tail.patch (553 bytes ) - added by SF/lblume 14 years ago.
Configure patch to use XPG4 tail on Solaris

Download all attachments as: .zip

Change History (14)

comment:1 by SF/lblume, 14 years ago

Priority: normallow

by SF/lblume, 14 years ago

Attachment: scummvm_configure.patch added

/bin/sh, tail & config.guess Solaris compatibility

comment:2 by SF/lblume, 14 years ago

While I'm at it, might as well remove the WARNING about the OS type.

comment:3 by SF/lblume, 14 years ago

If that matters, I meant SVN above, not CVS, sorry!

comment:4 by sev-, 14 years ago

Commited as is. Your fixes are clean. Thanks.

comment:5 by sev-, 14 years ago

Owner: set to sev-
Status: newclosed

comment:6 by fingolfin, 14 years ago

Actually, while "tail -1l" is accepted, it is an obsolescent form (see also <http:// www.opengroup.org/onlinepubs/007908799/xcu/tail.html>). On my system (Mac OS X), tail does work, but generates a warning about this outdated parameter form.

The POSIX standard has required the -n form for quite some form. What Solaris version are you using? I am surprised that it is not compliant in this regard...

comment:7 by fingolfin, 14 years ago

Keywords: script removed
Status: closednew

by SF/lblume, 14 years ago

Configure patch to use XPG4 tail on Solaris

comment:8 by SF/lblume, 14 years ago

It's the latest, Solaris 10 U1.

The problem is that Solaris has separate binaries for XPG4 (and now XPG6) compliant tools. Those in /usr/bin are keeping the Solaris backward compatibility. Those in /usr/xpg4/bin and /usr/xpg6/bin are standard-compliant, but they're not in the PATH by default.

So to use the current form, the script would need to use the standard version on Solaris only.

See my proposal in the new patch attached.

comment:9 by fingolfin, 14 years ago

Status: newclosed

comment:10 by fingolfin, 14 years ago

Excellent! Patch is in SVN now.

comment:11 by digitall, 17 months ago

Component: Ports

comment:12 by digitall, 17 months ago

Component: PortsPort: Solaris
Note: See TracTickets for help on using tickets.