Opened 14 years ago

Closed 14 years ago

Last modified 21 months ago

#2498 closed defect (wontfix)

compile error

Reported by: SF/mnbv Owned by: fingolfin
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

I just tried to build the latest code from svn (revision 20633) and got the following error:

g++ -Wp,-MMD,"engines/sword1/.deps/logic.d",-MQ,"engines/sword1/logic.o",-MP -Wall -g -ansi -W -Wno-unused-parameter -O -Wuninitialized -Wno-long-long -Wno-multichar -Wno-unknown-pragmas -pedantic -Wpointer-arith -Wcast-qual -Wconversion -Wshadow -Wimplicit -Wundef -Wnon-virtual-dtor -Wno-reorder -Wwrite-strings -fcheck-new -DHAVE_CONFIG_H -DUNIX -DDISABLE_LURE -I. -I. -I./engines -I/usr/include/SDL -D_REENTRANT -Itest/cxxtest -c engines/sword1/logic.cpp -o engines/sword1/logic.o /tmp/ccnO5g6d.s: Assembler messages: /tmp/ccnO5g6d.s:680: Error: undefined symbol `.LEHB5' in operation /tmp/ccnO5g6d.s:681: Error: undefined symbol `.LEHB5' in operation make[2]: *** [engines/sword1/logic.o] Error 1 make[2]: Leaving directory `/home/grahame/scummvm' make[1]: *** [scummvm] Error 2 make[1]: Leaving directory `/home/grahame/scummvm' make: *** [deb] Error 2

I'm using debian unstable (amd64) and gcc 4.0.2

This was a fresh checkout and compiled with: $./configure $ make deb

Ticket imported from: #1430201. Ticket imported from: bugs/2498.

Change History (4)

comment:1 by fingolfin, 14 years ago

"make deb", hu? No idea if that works, we are likely to remove it soon anyway.

I recommend you try a plain "make" and see if that works. Looking at your error message, though, the problem is likely something else -- frankly, the error makes no sense at all...

comment:2 by fingolfin, 14 years ago

The error disaplyed here hints at a compiler problem. It generates some assembler code from our source but then fails to assemble it. This is out of our control.

comment:3 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:4 by digitall, 21 months ago

Component: --Other--
Note: See TracTickets for help on using tickets.