Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2489 closed defect (wontfix)

FT: invalid seek request

Reported by: SF/peylow Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

I use: ScummVM 0.8.1, on Mac OS X 10.4.4 Full Throttle - Talkie with ogg-compressed audio.

ScummVM crashes when I enter the Old Mine Road from any exit after the vents with the fertiliser spillage. I have attached a save game, just climb the bike, go south (exit throught the bottom of the screen) and enter any exit, to replicate the crash.

The error message reads: ERROR: (13:82:0xD4D): invalid seek request : -1279183929 > 13113642 (delta == -1280810643)

Ticket imported from: #1424521. Ticket imported from: bugs/2489.

Attachments (1)

ft.s01 (22.2 KB ) - added by SF/peylow 14 years ago.
Save game just before crash

Download all attachments as: .zip

Change History (7)

by SF/peylow, 14 years ago

Attachment: ft.s01 added

Save game just before crash

comment:1 by fingolfin, 14 years ago

Summary: ERROR: () invalid seek requestFT: invalid seek request

comment:2 by fingolfin, 14 years ago

Owner: set to aquadran

comment:3 by fingolfin, 14 years ago

Likely caused by incorrect usage of the tools. Please read the explanation on bug #1390815 and see if that helps: <https://sourceforge.net/tracker/? group_id=37116&atid=418820&func=detail&aid=1390815>

Aquadran, can we modify the (FT relevant) compression tools to refuse to work if misused like this, to prevent problems for our users?

comment:4 by aquadran, 14 years ago

Status: newclosed

comment:5 by aquadran, 14 years ago

Resolution: wontfix

comment:6 by aquadran, 14 years ago

I see only solution to check san filenames to prevent compress uadio tracks. anyway i'm closing that bug due wrong usage of compress tool.

Note: See TracTickets for help on using tickets.