Opened 14 years ago

Last modified 12 months ago

#2477 pending defect (outdated)

MANIACNES: Walking and talking doesn't display properly

Reported by: SF/a60wattfish Owned by: digitall
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM Version: ScummVM 0.9.0cvs (Jan 28 2006 10:38:41)
Version of game: Maniac Mansion (U)
Platform: Win32

At the start of a new game, when you tell Dave to move
to the next screen he will start walking as normal,
then his legs will stop moving.
I think this only happens when you click on the
upperhalf of the grass, under the fence.

I have attached a screenshot showing this. He was still
moving when I took this. You can also see where I
clicked the curser, telling him to move across the screen.

Occasionally, when this occurs, once he gets to the
next screen he carrys on walking until he gets past the
doors of the house. I having problems reproducing this
part all the time, so I can't give you exact details of
where to click to cause this to happen.

Ticket imported from: #1417438. Ticket imported from: bugs/2477.

Attachments (1)

daves legs.PNG (41.4 KB ) - added by SF/a60wattfish 14 years ago.
Screenshot of Dave's legs not moving

Download all attachments as: .zip

Change History (6)

by SF/a60wattfish, 14 years ago

Attachment: daves legs.PNG added

Screenshot of Dave's legs not moving

comment:1 by SF/quietust, 14 years ago

The problem is that the NES costume code currently does not
keep track of walking and talking separately, so if an actor
starts OR stops talking while walking, the actor will slide
across the floor the rest of the way.

comment:2 by Kirben, 14 years ago

Also see bug report #1451698.

comment:3 by Kirben, 14 years ago

Summary: MANIACNES: Daves legs don't move at start sometimesMANIACNES - Walking and talking doesn't display properly

comment:4 by Kirben, 14 years ago

Summary: MANIACNES - Walking and talking doesn't display properlyMANIACNES: Walking and talking doesn't display properly

comment:5 by digitall, 12 months ago

Owner: set to digitall
Resolution: outdated
Status: newpending

The bug report referred to by Kirben is https://bugs.scummvm.org/ticket/2534 which is a duplicate so not critical.

This was reported on v0.9.0 (cvs) so very outdated.

Have just tested with latest git master i.e. 0b746971f103a620013dc9145ab6d3038e378192 on Linux x86_64 with Maniac NES English/GB and can not replicate the issue described.

If someone can replicate, we can investigate, but it is likely this may have been fixed by patches for MANIACNES between v0.9.0 and v2.1.0git :)

Setting as pending with resolution outdated. Should be closed in a month if no one has responded with a replication case by then.

Note: See TracTickets for help on using tickets.