Opened 15 years ago

Closed 15 years ago

Last modified 2 years ago

#2476 closed defect (fixed)

SCUMM: Game detection broken

Reported by: lordhoto Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

If I try to add a new game (for the scumm engine) in the current cvs I always get: "Assertion failed: len >= 5, file scumm/scumm.cpp, line 3187" it looks like that function is called with the parameter "zak" for filename, that is why that assertion should fail, I dunno enough about the scumm detection if it would be safe to just delete that assertion or decrease the value, so I report this bug. (Doesn't happen with branch-0-8-0)

Ticket imported from: #1416993. Ticket imported from: bugs/2476.

Change History (5)

comment:1 by sev-, 15 years ago

Max, it looks like it is a regression caused by your recent improvements. Though, I didn't look into the code carefully.

comment:2 by fingolfin, 15 years ago

I can't reproduce this. Please provide *detailed* instructions. Which game are you trying to add. At which point do you get that crash?

comment:3 by lordhoto, 15 years ago

Resolution: fixed
Status: newclosed

comment:4 by lordhoto, 15 years ago

It happend for all games, but I saw that cyx fixed it (Fri Jan 27 23:10:24 2006 UTC (17 hours ago) by cyx: A filename without an extension can be passed to generateSubstResFileName() ; changed assert() condition accordingly.)

Ok than this is fixed anyway.

comment:5 by digitall, 2 years ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.