Opened 15 years ago

Closed 15 years ago

#2432 closed defect (invalid)

DOTT: no music with alsa midi driver

Reported by: SF/theli_ua Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

tried to use fluidsynth and timidity ( yeah, i know that this is unrecommended but whatever ) as alsa sequencers ....

scummvm opens specified port fine : Connected to Alsa sequencer client [128:0] but then creates another port ( for what reason ??? ) : ALSA client initialised [129:0]

and ... no music :( (music works fine with adlib driver)

midi playback with that sequencers in any other app works fine ...

Ticket imported from: #1393582. Ticket imported from: bugs/2432.

Change History (18)

comment:1 by eriktorbjorn, 15 years ago

Odd, I get music when I try that. (In the case of Timidity, I get horribly broken-up music, but my computer may be too slow for it. It's a couple of years old... Removing the -B2,8 part of the command helps somewhat, but not much.)

I don't know enough about ALSA to answer the second question. But "aconnect -ol" reports:

client 64: 'EMU10K1 MPU-401 (UART)' [type=kernel] 0 'EMU10K1 MPU-401 (UART)' client 65: 'Emu10k1 WaveTable' [type=kernel] 0 'Emu10k1 Port 0 ' 1 'Emu10k1 Port 1 ' 2 'Emu10k1 Port 2 ' 3 'Emu10k1 Port 3 ' client 128: 'TiMidity' [type=user] 0 'TiMidity port 0 ' Connected From: 129:0 1 'TiMidity port 1 ' 2 'TiMidity port 2 ' 3 'TiMidity port 3 ' client 129: 'SCUMMVM' [type=user] 0 'SCUMMVM port 0 ' Connecting To: 128:0

So whatever that means, it looks like 128:0 is one end of the pipe, and 129:0 is the other.

Of course, Timidity needs a set of patches (or a SoundFont?) and Fluidsynth needs a SoundFont, but I assume you knew that already...

comment:2 by SF/theli_ua, 15 years ago

well.. ok client 129: 'SCUMMVM' [type=user] 0 'SCUMMVM port 0 ' Connecting To: 128:0 seems to be ok ...

but anyway .... i get no music ;(

and yeah.. i know about patches and soundfonts .. ( well, iv'e mentioned already that i can use that sequensers with other apps fine )

comment:3 by SF/theli_ua, 15 years ago

i've found out that this doesn't work with "day of tentacle only" while in other games it works fine ...

the same with seq and fluidsynth drivers

comment:4 by SF/theli_ua, 15 years ago

Component: --Unset--Engine: SCUMM
Game: Day of the Tentacle

comment:5 by eriktorbjorn, 15 years ago

Still works for me, even with Day of the Tentacle. (English talkie version.)

I would have suspected the volume settings, but you said it works with Adlib music so that shouldn't be it...

comment:6 by fingolfin, 15 years ago

Do you get music when you directly use the ScummVM fluidsynth driver (instead of ALSA) ?

comment:7 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:8 by fingolfin, 15 years ago

Summary: no music with alsa midi driverDOTT: no music with alsa midi driver

comment:9 by SF/theli_ua, 15 years ago

i have music with fmtowns and adlib drivers only in DOT

comment:10 by fingolfin, 15 years ago

Status: newpending

comment:11 by fingolfin, 15 years ago

Please answer the other questions I posted, too.

comment:12 by SF/theli_ua, 15 years ago

sorry.. just waked up... missed them

Game: Dott English/DOS Floppy Linux version 2.6.15-gentoo (root@theli) (gcc version 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9)) #1 PREEMPT Fri Jan 6 09:48:42 EET 2006

currently i use 0.8.0 but i'm downloading 20060114 snapshot now ...

as for bug details . i'v already posted them: there is now music in dott using alsa/seq/fluidsynth drivers.. while this drivers work in other games with scummvm and i can have music in dott with adlib or fmtowns drivers

comment:13 by SF/theli_ua, 15 years ago

Status: pendingnew

comment:14 by SF/theli_ua, 15 years ago

i can still reproduce this with 20060114 snapshot too

comment:15 by fingolfin, 15 years ago

The early DOTT floppy version only had Adlib music, but no MIDI music, so it's no surprise you have a problem.

There is a free update avaiable which adds it, I think, see here <http:// support.lucasarts.com/patches/dott.htm>.

comment:16 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newpending

comment:17 by SF/theli_ua, 15 years ago

Status: pendingclosed

comment:18 by SF/theli_ua, 15 years ago

yeah.. that's it :| sorry for invalid bug.

Note: See TracTickets for help on using tickets.