Opened 16 years ago

Closed 16 years ago

Last modified 3 years ago

#2431 closed defect (fixed)

Web site additions/changes

Reported by: SF/joachimeberhard Owned by: Kirben
Priority: normal Component: Web
Version: Keywords:
Cc: Game:

Description

Below is the entry in the compatibility list.

Now, you should also state Macintosh version, which you also support and it works.

Best regards

Joachim

Game should be completable, with several glitches - 3DO, DOS and Windows versions supported by this target - Piano sounds aren't correct pitch in DOS version

Ticket imported from: #1392850. Ticket imported from: bugs/2431.

Change History (40)

comment:1 by SF/joachimeberhard, 16 years ago

The Macintosh version of puttmoon and puttputt are also supported, so you could add that to the compatibility list as well.

I can confirm that puttmoon works, at least.

comment:2 by SF/joachimeberhard, 16 years ago

I know this isn't the right place, but I wonder why the target names sometimes use this naming convention:

CD All en a86f9c49355579c30d4a55b477c0d869 baseball2001 Kirben

CD All en 92e7727e67f5cd979d8a1070e4eb8cb3 puttzoo cyx

And then this convention:

CD All en c4ffae9fac495475d6bc3343ccc8faf9 Soccer2004 Kirben, sev

CD All en a525c1753c1db5011c00417da37887ef PuttTime Kirben

comment:3 by SF/joachimeberhard, 16 years ago

And while I'm pointing out so many nice things:

Could you remove the ":" in the md5 list here:

Big Thinkers: Kindergarten

comment:4 by SF/joachimeberhard, 16 years ago

I know what you must be thinking:

Maaaaaan, is this guy staring at the md5 list all day?!?

Ok, here are few more sugestions:

lowercase "Of", "To" and "The" in the md5 list consistently:

Putt-Putt Goes To The Moon

Putt-Putt Joins The Parade

Day Of The Tentacle

Best regards ;)

Joachim

comment:5 by SF/joachimeberhard, 16 years ago

And replace (from 5"25 floppies) with a (5.25") , would look nicer.

V2 (from 5"25 floppies) DOS de d06fbe28818fef7bfc45c2cdf0c0849d zak Nicolas Sauzède, Andrea Petrucci

Like in:

EGA (1.3 8/14/89 5.25") DOS en 6508fd55530e6915507e1cc37f7f045d indy3 Zer02

Also:

This version is included in the German 10 Adventures Pack
and has copyprotection enabled for sure in my version(just tested it):

V2 (w/o copy protection) DOS de cdd760228cf1010c2903f37e788ea31c zak Max Horn

So, maybe stating one as "Alt" and one without abbrevation would be better anyway.

Best regards

Joachim

comment:6 by SF/joachimeberhard, 16 years ago

And another suggestion:

While working on the detailed he-md5 list, I noticed that Eugene has a russian language version of this:

CD All en 590e6546aacd0d374b7f3a4f53013ab1 freddicove cyx

So it might be indicated to state "All" instead of "en"

Regards

Joachim

comment:7 by SF/joachimeberhard, 16 years ago

Yet, ANOTHER *sigh* suggestion: ;)

Put The Airport above "The Farm" in MD5 list.

comment:8 by Kirben, 16 years ago

The target names aren't consistant, since they are usually based on the exact filenames of index file.

I added most of your suggestions.

comment:9 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:10 by SF/joachimeberhard, 16 years ago

Hi kirben, I took a very close look on the compatibilty list, the md5 list and the he-list in the Wiki.

There are also a few typos on the Wiki like \' :

Pajama Sam's Lost & Found 1998 PC, Mac SCUMM
Pajama Sam\'s Sock Works 1999 PC, Mac SCUMM

Also, as an information to add to the Wiki HE list:

All 3 FunShop titles were released 2000.

I have a few more suggestions I'd like to make to the md5 list:

Compatibilty list:

Move BluesABCTimeDemo under BigThinker's series

MD5 list:

Put FirstGrade above Kindergarten, as you do in he list and compatiblity list.

Put maze over water, as you do in he list and compatibility.

Put socks over SamsFunShop

put pjgames down over SamsFunShop

Best regards

Joachim

comment:11 by SF/joachimeberhard, 16 years ago

Also, I'd recomend to backport the changes to the stable compatibility chart also, where possible.

Regarding the HE_list in the Wiki,

It would be better English to say:

"This is a list" instead of "This is list"

comment:12 by Kirben, 16 years ago

The Pajama Sam titles are already in correcet order on MD5 list.

I added your other suggestions.

comment:13 by SF/joachimeberhard, 16 years ago

Hm, then I might suggest to consider changing this order:

Putt-Putt's Fun Pack 1994 3DO, PC, Mac SCUMM
Putt-Putt & Fatty Bear's Activity Pack 1999 PC, Mac SCUMM
Putt-Putt's One-Stop Fun Shop 2000 PC, Mac SCUMM

I took this from the HE-List, it's consistent throughout compatibility/md5/he-list in wiki right now.

Also some more suggestions the compatibility list:

stable: Simon The Sorcerer, lowercase "The"

stable&cvs: Use "Putt-Putt's Fun Pack" instead of "Putt-Putts Fun Pack"

Regarding the Wiki and Compatibility chart: You don't use "Spyfox" or "Spy Fox" consistently.

Finally, I'd like to add that "Spy Fox in Cheese Chase Game" actually just is called "Spy Fox in Cheese Chase", at least on my CD. I'd suggest to change this throughout compatibility/md5/he-list.

Best regards

I hope I don't get on your nerves by now ;)

Joachim

comment:14 by SF/joachimeberhard, 16 years ago

And I really cant persuade you to put

Pajama Sam: Games to Play On Any Day CD All en 8a484262363a8e18be87112454f1456b pjgames Kirben

below

Pajama Sam 3: You Are What You Eat From Your Head to Your Feet

?? It would fit better by type of games.

Also, I'd still suggest sorting this way also:

Putt-Putt & Fatty Bear's Activity Pack Putt-Putt's Fun Pack

Best regards

Joachim

comment:15 by SF/joachimeberhard, 16 years ago

You have resorted it this way in the Wiki, now I'd suggest to sort it this way in the compatibility (stable/cvs)/md5list/readme(081/CVS) also. Also be aware that those games are above the Junior Adventures at the moment in the Readme(081/CVS).

Putt-Putt & Fatty Bear's Activity Pack Putt-Putt's Fun Pack

Also "Putt-Putt Goes To The Moon" is not consistent with the others in the Readme(081/CVS).

In the md5 list I'd like to suggest to remove "from floppies" from the following entry, V2 (5.25") should suffice.

V2 (from 5.25" floppies) DOS de d06fbe28818fef7bfc45c2cdf0c0849d zak Nicolas Sauzède, Andrea Petrucci

Also, I'd (sigh) still sugest to sort pajams sam this way:

pajama pajama2 pajama3 pjgames lost SamsFunShop socks

I will incorporate all changes in the he-md5-details also.

Best regards, if I could I'd send you a bottle of champagne to celebrate the new md5 list/compatibility list/readme. I really like consistency ;)

Joachim

comment:16 by Kirben, 16 years ago

I left the comment as '(from 5.25" floppies)' in the MD5 list, as people might not realise what the '5.25"' means.

I added all the other suggestions.

comment:17 by SF/joachimeberhard, 16 years ago

Watching the cvs logs, I think you have updated now everything except the compatibility list with:

Putt-Putt & Fatty Bear's Activity Pack Putt-Putt's Fun Pack

The rest REALLY looks good now.

Best regards

Joachim

comment:18 by Kirben, 16 years ago

Compatibility list updated now too.

comment:19 by SF/joachimeberhard, 16 years ago

I wonder why the compatibility list doesn't get updated, though you changed it...

Also, I saw that in the ReadMe you say:

Indiana Jones & the Last Crusade

instead of:

Indiana Jones and the Last Crusade

Also, why don't you align all targets in one column in the Readme?

I also think it's save to add at least pajama3 and spyozone to the fully playable list in the Readme, since there aren't any major bugs when completing them...

Best regards.

Joachim

comment:20 by SF/joachimeberhard, 16 years ago

I also have a few suggestions for the faq:

1.7 -> Elaborate that the daily builds are precompiled installers or whatever, so less people assume they have to compile it themselves.

3.1 -> The fmtowns games zak, indy3, loom and monkey and sega cd monkey use cd audio also.

4.7 -> I think you don't need 4.7 anymore, since you now have a sophisticated game detection.

4.9 -> (last paragraph) Nowadays, setting the platform manually shouldn't be necessary due to game detection. You could safely remove this to lessen confusion (I think).

Best regards

Joachim

comment:21 by SF/joachimeberhard, 16 years ago

Pajama Sam's Lost & Found is even stated with "no glitches" in 080 release testing, so you could also change that in both readmes:

http://wiki.scummvm.org/index.php/Release_Testing

comment:22 by Kirben, 16 years ago

I corrected indy3 title in the readme.

All the targets in readme used to be alligned, but were changed due to a 80 characters per line limit on some systems.

Pajama Sam 3 still has major issues, due to lack of support for sprite scaling and zooming, which is used during the credits and ski ride.

Spy Fox 3 still has major issues, due to lack of support for 16bit color, which causes many palette glitches.

Pajama Sam's Lost & Found still has many glitches during game play too, depending on the version.

Check the HE Progress page on wiki at http://wiki.scummvm.org/index.php/HE_Progress for more details about issue in HE games.

comment:23 by Kirben, 16 years ago

I added changes to the FAQ on web site.

4.7 & 4.9 -> Best to keep these sections, as we might not have all Amiga & Macintosh versions (of SCUMM games) covered by our MD5 list and it could be useful for people using older versions of ScummVM too.

comment:24 by SF/joachimeberhard, 16 years ago

You're the boss ;)

I'm very much reviewing all available infos on the various places on the website, as these are the things users consider first for information.

I don't contribute any thoughts about the screenshots pages yet, but I have looked into it a bit.

Do you think I'm doing ok or do you think I'm too picky with these things?

Also, should I continue filing docs/website thoughts here or somewhere else?

Best regards

Joachim

comment:25 by Kirben, 16 years ago

Summary: Compatibility list additionWeb site additions/changes

comment:26 by Kirben, 16 years ago

Your suggestions are always welcome and I don't think you are too picky. It really helps to have peeople go over our documentation and improve it.

Might as well just keep using this bug report for now.

comment:27 by SF/joachimeberhard, 16 years ago

Some more small corrections regarding the faq before I go to bed:

3.1 mention monkey1 fmtowns also.

3.1 use comma instead of dot and continue with y insted of Y.

Best regards

Joachim

Quote:

If you have more than one CD drive in your system. You can specify your CD drive using the -c command line parameter

comment:28 by SF/joachimeberhard, 16 years ago

Someone in the forum pointed out, that in the faq of AGS is no longer existing. The link is dead.

FAQ #1.6

Its author keeps his source code closed due to reasons explained in the project FAQ (see last two questions). That means that you need to download that program to play the game.

comment:29 by SF/joachimeberhard, 16 years ago

BTW: You forgot to update the CVS Readme:

Indiana Jones & the Last Crusade

And in both 080 and CVS branch readme's you sort:

The Dig [dig] Full Throttle [ft]

It should be the other way around.

And in the compatibility lists:

Indiana Jones 4 and the Fate of Atlantis

Maybe remove the "4" for consistence...

And with monkey2: The "R" in Revenge could be uppercase...

Best regards,

Joachim

comment:30 by SF/joachimeberhard, 16 years ago

Also, I think you should state:

Zak McKracken and the Alien Mindbenders Monkey Island 2: LeChuck's Revenge

instead of Zak McKracken and Monkey Island 2 in both Readmes, because thats how you name it in game detection.

Also, I think it couldn't hurt to rename "The" from comi in game detection, because thats the way you call the game everywhere else...

And if you change that, you could uppercase the "R" of monkey2 in the game detection, the compatibility lists, and tge md5 list as well.... ;)

Best regards

Joachim

comment:31 by Kirben, 16 years ago

I added all your suggestions and fixed the link in the FAQ.

I double checked game title names on History section of LucasArt's web site, to be sure all are correct now.

comment:32 by SF/joachimeberhard, 16 years ago

Looks great.

But you forgot to remove the 4 after Indiana Jones in the CVS compat. chart.

I wonder what you chose for game detection, as I cant see the cvs changes yet...

comment:33 by Kirben, 16 years ago

Ooops, removed the 4 left on compatibility list too.

The game detection in SCUMM engine, uses the exact same game titles, as currently listed on compatbility list.

comment:34 by SF/joachimeberhard, 16 years ago

The Curse of The Secret of Monkey Island

loooool

However, you mistakenly replaced "Monkey Island" instead of "Monkey Island 1" in the scumm.cpp

So we end up with:

The Secret of Monkey Island 2: LeChuck's Revenge

And many others changed at least in branch-080.

It would be safer to get back before you changed "Monkey Island" and start safeley from there.

Look in the CVS logs to see why it would be safer.

comment:35 by Kirben, 16 years ago

Fixed now, I mucked up the search/replace on scumm/scumm.cpp of the 0.8.0 branch.

comment:36 by SF/joachimeberhard, 16 years ago

Hey, I'm getting familiar with reading code and understanding the basics of ScummVM development :D

I like that. It's never too late. ;)

comment:37 by SF/joachimeberhard, 16 years ago

I have asked kaminari, and he has confirmed that this:

CD Mac fr 21a6592322f92550f144f68a8a4e685e dig kaminari

is a mac bundle version.

Also, this is the only item still not sorted properly.

You also missed an md5 report to the devel-mailinglist from 2005-11-09 :

From: VooD <musixnow@te...> Loom Amiga Spanish MD5
2005-11-09 23:11

48b9f04b348bc5013327753f0d12a144

Regards

Joachim

comment:38 by SF/joachimeberhard, 16 years ago

Also, state one of these as "Alt":

V2 DOS fr 52a4bae0746a11d7b1e8554e91a6645c zak Andrea Petrucci V2 DOS fr c4787c3e8b5e2dfda90850ee800af00f zak Qvist

Best regards

Joachim

comment:39 by Kirben, 16 years ago

Done.

comment:40 by digitall, 3 years ago

Component: Web
Note: See TracTickets for help on using tickets.