Opened 15 years ago

Closed 15 years ago

Last modified 20 months ago

#2426 closed defect (fixed)

FARMDEMO MAC MD5

Reported by: SF/joachimeberhard Owned by: Kirben
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Dear ScummVM team!

These are the details for FARMDEMO Mac.

The game starts with ScummVM, but exits with an error code attached at the bottom of this message.

Farm Demo
19a57595f7d2367286058a41241e574a Farm Demo (0)
39fd6db10d0222d817025c4d3346e3b4 Farm Demo (1)
ba3cb50770848a91216565b91edf8579 Farm Demo (2)
706d44b32f7c74e98ff4fe88d625826d Farm Demo (4)
ad6a4dea7b696a28b99d40ea1d685788

Debuglevel (from command line): 0 Looking for farm Trying to start game 'Let's Explore the Farm with Buzzy' Unknown MD5 (39fd6db10d0222d817025c4d3346e3b4)! Please report the details (langu age, platform, etc.) of this game to the ScummVM team ScummEngine_v72he readMAXS: MAXS has blocksize 40 Total music tracks 1 DEBUG: machine-speed = FAST-MACHINE o72_readINI: Option TextOn DEBUG: number of sound channels is 0 o72_readINI: Option NoBackGroundSound Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Ticket imported from: #1392343. Ticket imported from: bugs/2426.

Change History (18)

comment:1 by Kirben, 15 years ago

I added the details for the Macintosh version, try the current Windows snapshot of ScummVM.

comment:2 by Kirben, 15 years ago

Keywords: detection added
Owner: set to Kirben

comment:3 by SF/joachimeberhard, 15 years ago

The other demos work.

This one still crashes:

Debuglevel (from command line): 0 Looking for farm Trying to start game 'Let's Explore the Farm with Buzzy' ScummEngine_v6 readMAXS: MAXS has blocksize 40 Bad ID 49440001('ID') found in index file directory!!

comment:4 by Kirben, 15 years ago

Could you please put the Mac. demo on your FTP site, so I can have a closer look at the issue.

comment:5 by SF/joachimeberhard, 15 years ago

Ok, this is going to take about 40mins....

I post in here, when it's ready.

comment:6 by SF/joachimeberhard, 15 years ago

I uploaded the demo.

Best regards

Joachim

comment:7 by SF/joachimeberhard, 15 years ago

Looks like it works now....

Thanks

comment:8 by Kirben, 15 years ago

Thank you for the Macintosh demo but the problem has not been fixed yet.

The problem is the introduction of the demo causes memory corruption, in both the Macintosh and Windows versions. So the demos will often crash during the introduction.

comment:9 by Kirben, 15 years ago

Priority: normalblocker

comment:10 by SF/joachimeberhard, 15 years ago

Is this the case for bug 1390573 also?

I closed it because for my not so high standards The Airport was working, played it for quite some time...

comment:11 by SF/joachimeberhard, 15 years ago

I'm asking because the farm/jungle/airport games seem to be the only ones where a file like this:

Farm Demo 19a57595f7d2367286058a41241e574a

has any importance and needs to be copied in MacBinary format.

Correct me, if there are more games that need the executables copied in MacBinary...

comment:12 by Kirben, 15 years ago

The problem you reported in Macintosh version of airport is unrelated.

Only the Macintosh versions of airport, farm, jungle and puttzoo require the main file to be copied in MacBinary format. Since the mouse resources are stored in the resource fork of main file, as part of game code.

comment:13 by SF/joachimeberhard, 15 years ago

But the binary file is only necessary for this version:

CD Mac en 58fdf4c7ad13540a734e18f8584cad89 puttzoo khalek

not for this:

CD All en 92e7727e67f5cd979d8a1070e4eb8cb3 puttzoo cyx

Right? Because my "All" Mac Version runs without the executable, and I don't have the first one...

comment:14 by SF/joachimeberhard, 15 years ago

Just to avoid confusion, Airport runs fine, Jungle doesn't.

comment:15 by Kirben, 15 years ago

Yes, the main file is only required for the original release of the Macintosh version of puttzoo.

You own the updated version of puttzoo, which was released later, so it isn't required.

comment:16 by Kirben, 15 years ago

Fixed the crashes, use the current Windows snapshot.

comment:17 by Kirben, 15 years ago

Keywords: detection removed
Resolution: fixed
Status: newclosed

comment:18 by digitall, 20 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.