Opened 14 years ago

Closed 14 years ago

Last modified 17 months ago

#2420 closed defect (fixed)

MD5: JUNGLE MAC MD5

Reported by: SF/joachimeberhard Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Dear ScummVM team!

There is also a Mac version on the CD:

Best regards

Joachim

Win:

JUNGLE.HE0
8801fb4a1200b347f7a38523339526dd JUNGLE.HE1 100% 1b39261e8d7e7384cf47fe9a6fa808d8 JUNGLE.HE2
9a5bf899124f45288749d81a0918907a JUNGLE.HE3
c0e6ea1d47493cca09fc674c3d097836 JUNGLE.HE4 100% 222ad352670c1d94366a8511af846f49 JUNGLE.HE9
f80c48c622ba21d46fc518630f324cf7 JUNGLE.HLP
b73780cbd4e5c52588453fadd5865456 JUNGLE.INF
21ff72adc411be8b4d5a67ee4ae87cb2 JUNGLE.W32
d8561c70fe52082eace566fe038995f7

Mac:

The Jungle (0)
659942b9a6b519f123a13cca3c333a13 The Jungle (1) 100% 0212155e5de27230b4ce5e36fb910945 The Jungle (2)
9a5bf899124f45288749d81a0918907a The Jungle (4)
222ad352670c1d94366a8511af846f49 The Jungle (9)
f80c48c622ba21d46fc518630f324cf7

Ticket imported from: #1390578. Ticket imported from: bugs/2420.

Change History (17)

comment:1 by SF/joachimeberhard, 14 years ago

Oh, and the Mac demo for Freddi1 should go up the list, for consistence.

I knew I'd find something ;) :D :)))

comment:2 by Kirben, 14 years ago

Owner: set to Kirben

comment:3 by Kirben, 14 years ago

I added the details for the Macintosh version, use the current Windows snapshot of ScummVM.

comment:4 by SF/joachimeberhard, 14 years ago

Hi kirben

This is the error it produces:

Looking for jungle Trying to start game 'Let's Explore the Jungle with Buzzy' (0:1:0x63): Resource fork is missing in file 'The Jungle'

comment:5 by Kirben, 14 years ago

Choose 'MacBinary' when copying the 'The Jungle' from the CD, since ScummVM requires the resource fork.

comment:6 by SF/joachimeberhard, 14 years ago

Well, when I choose MacBinary, I end up with all *.bin files, no file more, no file less, and it doesn't help much.

Instead, I think the problem is the missing .he3 file in the Mac version.

It seems that this file is somehow incorporated into the The Jungle (1) file, since it is a little bit larger in the Mac version (around 20K).

Look at the md5s, you see only the first files differ.

Maybe this could be a lead...

comment:7 by Kirben, 14 years ago

The resources for the mouse cursors are stored in the main executable files (ie 'The Jungle') in the early Macintosh version of HE games, which is why there are no *.HE3 files.

Just to be sure, you did copy the 'The Jungle' file from the CD too? as I noticed it was not listed in initial report.

comment:8 by SF/joachimeberhard, 14 years ago

Yes, I copied the main executable in the first place, I just didn't copy/paste it.

So here goes:

The Jungle
5f305d75c9e6138d042ea7cd248d1d84

comment:9 by SF/joachimeberhard, 14 years ago

With "didn't copy/paste it" I mean I didn't copy/paste the md5 in here, in this report.

comment:10 by SF/joachimeberhard, 14 years ago

Ok, when I copy only the file "The Jungle" as MacBinary, rename the "The Jungle.bin" to "The Jungle" and overwrite the "datafork" version, this particular problem goes away.

However now it exits with claiming jungle.he9 is missing, although I have "The Jungle (9)" in the datafork version in the folder...

comment:11 by SF/joachimeberhard, 14 years ago

This is the correct md5 of the executable, copied in MacBinary:

The Jungle
0e896300a0af8bd43f82d57a9da6a525

comment:12 by Kirben, 14 years ago

Could you please provide a debug level 9 log, to help track down the cause of this issue. ie scummvm -d9 jungle > jungle.txt

comment:13 by SF/joachimeberhard, 14 years ago

The Jungle Mac works somehow now, but I haven't changed anything, just using the latest build now.

Maybe I just didn't download the latest build at that time.

As there is a bugreport regarding the game detection issue, I file the following game detection related bugreport there too, so you may close this bugreport.

Oh, and another thing: using scummvm -d9 >jungle.txt and playing it for 5 minutes, I ended up with a 122MB file ;) I hope you don't expect me to upload it ;) :D

There is a game detection related bug with the Jungle Mac version, as the oldest HE Games show the Windows part of the CD on the Mac part also. That means, that when I copy everything in the Mac fork of the CD to a folder on my harddisk, it contains the Windows and the Mac version of the game.

Coosing and starting the Windows version in the launcher results in the following error:

ERROR: (0:1:0x63): The Jungle: not a Windows library

All md5s match the Windows version, which works fine in a seperate folder.

Regards Joachim

comment:14 by fingolfin, 14 years ago

Summary: JUNGLE MAC MD5MD5: JUNGLE MAC MD5

comment:15 by Kirben, 14 years ago

Closing, since we will not support multiple games in a single directory, especially in the case of HE games.

It is really unfortunate that the Macintosh and Windows versions are mixed in this case, but people will have to copy the data files over manually.

comment:16 by Kirben, 14 years ago

Resolution: fixed
Status: newclosed

comment:17 by digitall, 17 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.