Opened 14 years ago

Closed 14 years ago

#2405 closed defect (duplicate)

BASS: breakdown on the bottom level

Reported by: SF/mzatt Owned by: lavosspawn
Priority: normal Component: Engine: Sky
Keywords: script Cc:
Game: Beneath a Steel Sky

Description

I'm using ScummVM version 0.8.0, using Win32 platform
and compiler.

The problem occurs in the Talkie version of "Beneath
a Steel Sky", English language.

Okay, it seems like this has already been noted in
other manifestations, but I'll repeat mine here:

I went into Mrs. Piermont's apartment and convinced
her to sponsor me for the club. Whilst she was
talking on the phone, she switched from speech to
text. Meanwhile, I put the videotape in the VCR and
got the dog biscuits. By this time, one of Mrs.
Piermont's sentences has frozen in place and the
others were just cycling behind it. I waited for a
while and nothing else seemed to happen, except the
cursor stopped showing its description of hotspots
when I highlighted them. I left the apartment and re-
emerged on the ground level, saved, and then things
started getting worse. I tried to talk to some of
the characters but no speech options appeared -
instead some random graphics started popping up and
the inventory came down. I was effectively locked
out since I couldn't complete the conversation or do
anything else. I tried restoring to my saved game,
but the same thing happened.

I'm attaching a saved game - I'm afraid that it
occurs right after the bug, not before, but as far as
I can tell the bug was triggered when Mrs. Piermont
started talking on the phone.

This is the first time I've ever used ScummVM, so
I've no idea if this has occurred with previous
versions.

Any help at all would be great, even if it means I'd
have to reinstall ScummVM and or / BASS and start the
game over ... I was just starting to really enjoy the
game when it all fell to pieces! Plus, the ScummVM
project as a whole is such a wonderful idea.

Thanks very much,

Matt

Ticket imported from: #1378297. Ticket imported from: bugs/2405.

Attachments (2)

SKY-VM.000 (14.8 KB ) - added by SF/mzatt 14 years ago.
Saved game
SKY-VM.001 (14.6 KB ) - added by SF/mzatt 14 years ago.
A new saved game

Download all attachments as: .zip

Change History (7)

by SF/mzatt, 14 years ago

Attachment: SKY-VM.000 added

Saved game

comment:1 by fingolfin, 14 years ago

Owner: set to lavosspawn

comment:2 by fingolfin, 14 years ago

This looks like it might be a duplicate of bug #1314495 ...

by SF/mzatt, 14 years ago

Attachment: SKY-VM.001 added

A new saved game

comment:3 by SF/mzatt, 14 years ago

A quick update - I played my way through the game right
from the beginning.

Firstly, I was able to save the game just before entering
Mrs. Piermont's flat, so you have the opportunity to
reproduce the bug yourself.

Secondly, I think that the 'freezing in place' of one of
Mrs. Piermont's sentences was caused by the player using
the inventory whilst one of her sentences was on display.
For whatever reason, the game couldn't clear it once the
player had left the inventory.

Thirdly, I was able to avoid the bug entirely once Mrs.
Piermont was on the phone by simply performing the
necessary actions (i.e. putting on the video, grabbing the
dog biscuits) and leaving as quickly as possible. The
rest of the game carried on as normal, which leads me to
observe:

Fourthly, I forgot to mention that I tried talking to Mrs.
Piermont before I left her flat, so this may have been the
trigger for the bug to worsen. I didn't talk to her at
all when I managed to avoid the bug.

That's it, I think. Thanks for taking notice.

Matt

comment:4 by fingolfin, 14 years ago

Resolution: duplicate
Status: newclosed

comment:5 by fingolfin, 14 years ago

Closing this as a duplicate of bug report
#1314495, where the issue is described with
some detail.

Note: See TracTickets for help on using tickets.