Opened 14 years ago

Closed 13 years ago

Last modified 12 months ago

#2379 closed defect (wontfix)

MACOSX: Won't mount audio & data of the MI CD together

Reported by: SF/jorweeck Owned by: fingolfin
Priority: low Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

I'm running the latest build of ScummVm (0.8.0a) on my mac and I can't
run Loom or Monkey Island CD with it.

I spot the problem to be more with the Mac OSX since it detects the CD as
an audio disc instead of data. Thus, ScummVM couldn't detect it as well.

Is there a solution you guys can do to help fix/bypass this problem?

Godspeed,
--jones

PS. You guys ROCK!!!

Ticket imported from: #1366103. Ticket imported from: bugs/2379.

Change History (18)

comment:1 by fingolfin, 14 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 14 years ago

This is indeed not a problem with ScummVM, but rather with OS X. This used to
work fine, but indeed I just tried and on my 10.4 system I can't mount both
sessions of my Monkey CD... hmm
Maybe this broke with 10.4 ?

The following might help you mount it. I'll see if I can find an easier way, so we
can add it to the FAQ/README or so...

comment:3 by fingolfin, 14 years ago

Sorry, this is the link I wanted to include: <http://forums.osxfaq.com/
viewtopic.php?
t=4512&highlight=hybrid&sid=ca9fc91181b035ca8728d31f31d03b1b>

comment:4 by fingolfin, 14 years ago

Summary: Moneky Island ProblemsMI (CD): Mac OS X won't mount audio & data volume together

comment:5 by (none), 14 years ago

"Mac OS X won't mount audio & data volume together". Ehm, this is normal
for a Mac user. A lot of old games are written in mixed mode. On Mac this
create the "problem" of "audio and data mounted separately", on Win this
create the "problem" of "invisible audio tracks (need to open a player to see
them)". However is normal, and on a Mac, the solution (i think) is to rip the
tracks and put all in a folder (as the Gobliiins Faq, on the other hand).

comment:6 by fingolfin, 14 years ago

"Mac OS X won't mount audio & data volume together" in this
case means: On some systems, you get two icons when you
insert a hybrid / dual mode CD. One for the Audio part, one
for the data part.

This isn't always the case. It is *always* possible to force
both volumes to appear (e.g. by using some unix commands,
see the URL I mentioned in an earlier comment to this
tracker item).

It has never been the case (and should never be so) that the
different data is somehow "merged" into a single volume.

And the solution, unfortunately, is *not* to rip the audio
data, either -- because it is useless to do so as long as
you can't even *access* the game data! (as is the case here,
unless you use e.g. unix commands).

Finally, this is not a bug or issue of ScummVM itself,
however, it is a sever issues that affects all mac users and
as such I think we should document it in the FAQ or another
suitable location, which is why I left it open.

comment:7 by (none), 14 years ago

Ah, ok then. So we are not talking about the "two icons when i put a hybrid
cd" question (that depend from system architecture), but about the
"sometimes data/audio folder are not mounted correctly" question. The
summary title is a bit incorrect then, according to me...

comment:8 by fingolfin, 14 years ago

Err, no. We are indeed talking about the "two icons when I
put a hybrid CD into my drive" question -- although "hybrid"
is the wrong term here, it's used for CDs which have, for
example, both a HFS and an ISO filesystem (which then can
share data, too), while in this particular case it's a multi
session CD with a *data* part and an *audio* part.

Abd the problem is that there are *not* two icons display.
In fact, the system believes the ISO part of the CD to be an
invalid HFS volume. Well, that's in fact correct, any
ISO9660 volume is "invalid HFS", but that's obviously
besides the point :-).

As a result, the only way to access the data part is to use
mount/mount_cd9660, forcing the system to mount the data
track as an ISO9660 volume.

comment:9 by (none), 14 years ago

Ah, in the sense of "when i mount an hybrid cd, usually create two icons, but
this time does not appear nothing (so i cannot do anything)". Humm.
However, at this point, i think that "jorweeck problem" is a 10.4.x (1,2,3,?)
issue too, and he should report it to Apple Support (if it was not solved yet).

comment:10 by fingolfin, 14 years ago

The problem has been present in one form and another in every Mac OS /
MacOS version, including pre-X versions.

My cousin, from how I got my MI CD, wasn't able to get the data from it either,
using 10.2 or 10.3 (I don't recall for sure) while it was no problem to do so on
my system. And yeah, of course this all should be submitted to Apple (I already
did, it won't hurt if everybody else did the same).

comment:11 by fingolfin, 14 years ago

Note that many other game CDs I own which contain both audio and data tracks
work flawlessly under OS X. It's only the Monkey Island CD that suffers from this
problem.

comment:12 by fingolfin, 14 years ago

Priority: normallow

comment:13 by fingolfin, 14 years ago

Note that many other game CDs I own which contain both audio and data tracks
work flawlessly under OS X. It's only the Monkey Island CD that suffers from this
problem.

comment:14 by fingolfin, 14 years ago

Summary: MI (CD): Mac OS X won't mount audio & data volume togetherMACOSX: Won't mount audio & data of the MI CD together

comment:15 by sev-, 13 years ago

Anything we can do with it then?

comment:16 by fingolfin, 13 years ago

Resolution: wontfix
Status: newclosed

comment:17 by fingolfin, 13 years ago

If this ever comes up again, we can consider adding it to the FAQ / README. But
we can't do anything about it other than telling people about the cause of the
problem.

comment:18 by digitall, 12 months ago

Component: Port: Mac OS X
Note: See TracTickets for help on using tickets.