Opened 14 years ago

Closed 14 years ago

Last modified 7 months ago

#2364 closed defect (fixed)

SIMON: Drawing regression in Simon 1 and 2

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

With the latest CVS, a lot of things in Simon 1 and 2
are no longer drawn. E.g. at the beginning of the Simon
2 intro, only the background is visible, and it gets
even worse after that.

The immediate culprit seems to be this line in vc10_draw():

memset(&_video_windows, 0, sizeof(_video_windows));

but since I don't know which purpose it serves, I don't
dare to simply remove it, or even make it conditional.

Ticket imported from: #1357532. Ticket imported from: bugs/2364.

Change History (4)

comment:1 Changed 14 years ago by eriktorbjorn

Owner: set to Kirben

comment:2 Changed 14 years ago by (none)

see SIMON2DOSTALKIE: rate effect freeze

comment:3 Changed 14 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:4 Changed 7 months ago by digitall

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.