Opened 14 years ago

Closed 13 years ago

Last modified 11 months ago

#2363 closed defect (fixed)

HE Games: Unknown versions

Reported by: SF/iziku Owned by: Kirben
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

In both airport, puttmoon and puttzoo the subtitles
config parameter appears to be ignored on startup. I
have them set for no subtitles and I get subtitles
displayed. I can turn them off by cycling thru with
ctrl+t but this only lasts until I exit, they're back
again next time. puttcircus, putttime, funpack and
puttrace all behave as expected.

I also seem to have unknown versions of putttime and
funpack.

Balloon won't work at all, gives an unknown md5 and Bad
ID 1000100 found in index file directory. I can play
balloon fine with the original game .exe.

Is it possible to reconfigure the exit key to 'esc'
instead of ctrl+z or alt+x? puttmoon and funpack have
no ingame exit option and if I run them fullscreen my 4
year old has trouble figuring out how to exit.

I'm running under Windows XP, english and v0.9.0.0
(nov. 9 cvs)

Thanks.

Ticket imported from: #1357135. Ticket imported from: bugs/2363.

Attachments (1)

log.zip (58.1 KB ) - added by SF/iziku 14 years ago.
freddi -d9 log (zipped)

Download all attachments as: .zip

Change History (27)

comment:1 by Kirben, 14 years ago

Owner: set to Kirben
Summary: subtitlesHE Games:Subtitles can't be disabled

comment:2 by Kirben, 14 years ago

Please start ScummVM from a Command Prompt with a
debug level of 1 and provide the details reported for each
unknown version oof game. ie
scummvm -d1 balloon

Also please list the language and version (Macintosh or
Windows) of each unknown game. Then we can add those
details to ScummVM.

No, the main exit keys used by ScummVM would not be
changed at this stage. The scripts of many SCUMM games
used the ESC key to skip cut scenes, so it couldn't be used
as an exit key anyway.
Maybe you can find a utility to remap keys on your system
instead?

comment:3 by Kirben, 14 years ago

The subtitles not been disabled issue in airport, puttmoon
and puttzoo is fixed now. Use the current Windows snapshot
of ScummVM.

comment:4 by Kirben, 14 years ago

Summary: HE Games:Subtitles can't be disabledHE Games:Unknown versions

comment:5 by SF/iziku, 14 years ago

I confirm that the subtitles issue is fixed in the games
previously listed, many thanks! :)

Following is info on my unkown versions.

-balloon- windows / english
Debuglevel (from command line): 1
Looking for balloon
Trying to start game 'Putt-Putt and Pep's Balloon-O-Rama'
Output sample rate: 22050 Hz
Unknown MD5 (d7b247c26bf1f01f8f7daf142be84de3)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
ScummEngine_v72he readMAXS: MAXS has blocksize 52
Bad ID 1000100('?') found in index file directory!!

-putttime- windows/english
Debuglevel (from command line): 1
Looking for putttime
Trying to start game 'Putt-Putt Travels Through Time'
Output sample rate: 22050 Hz
Unknown MD5 (63fdcdc95cdeea00060883aed38e5504)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
ScummEngine_v72he readMAXS: MAXS has blocksize 40

-funpack- dos/english
Debuglevel (from command line): 1
Looking for funpack
Trying to start game 'Putt-Putt's Fun Pack'
Output sample rate: 22050 Hz
Unknown MD5 (3d219e7546039543307b55a91282bf18)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
ScummEngine_v6 readMAXS: MAXS has blocksize 38

I could make copies available if necessary/desired.

comment:6 by Kirben, 14 years ago

I added the details of those games to ScummVM, please try
the current Windows snapshot of ScummVM and let us know the
results.

comment:7 by SF/iziku, 14 years ago

Just tried the lastest snapshot:

D:\ScummVM>scummvm -d1 balloon
Debuglevel (from command line): 1
Looking for balloon
Trying to start game 'Putt-Putt and Pep's Balloon-O-Rama'
Output sample rate: 22050 Hz
Unknown MD5 (d7b247c26bf1f01f8f7daf142be84de3)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
ScummEngine_v72he readMAXS: MAXS has blocksize 52
Bad ID 1000100('☺') found in index file directory!!

It also automatically identifies the platform as default
instead of windows.

my putttime copy is also being identifed as balloon /
windows / english and now won't run at all.

D:\ScummVM>scummvm -d1 balloon
Debuglevel (from command line): 1
Looking for balloon
Trying to start game 'Putt-Putt and Pep's Balloon-O-Rama'
Output sample rate: 22050 Hz
Unknown MD5 (d7b247c26bf1f01f8f7daf142be84de3)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
ScummEngine_v72he readMAXS: MAXS has blocksize 52
Bad ID 1000100('☺') found in index file directory!!

doh!

comment:8 by SF/iziku, 14 years ago

D:\ScummVM>scummvm -d1 putttime
Debuglevel (from command line): 1
Looking for putttime
Trying to start game 'Putt-Putt Travels Through Time'
Output sample rate: 22050 Hz
ScummEngine_v99he readMAXS: MAXS has blocksize 40
Bad ID 5040302('♣♦♥☻') found in index file directory!!

sorry, correct output for second 1/2 of my last comment...
(putttime) bad paste...

comment:9 by Kirben, 14 years ago

Sorry, I mixed up one of the md5 values in the last
changes. Please try the current Windows snapshot of ScummVM
and let us know the results.

comment:10 by SF/iziku, 14 years ago

putttime is now identifed correctly and working. balloon
tries to start, throws me into a debugger console. I type
exit, it bails and this is the output.

D:\ScummVM>scummvm -d1 balloon
Debuglevel (from command line): 1
Looking for balloon
Trying to start game 'Putt-Putt and Pep's Balloon-O-Rama'
Output sample rate: 22050 Hz
ScummEngine_v99he readMAXS: MAXS has blocksize 52
vars[212] = 0 (via script-0)
vars[212] = 861114369 (via script-0)
vars[213] = 0 (via script-0)
vars[213] = 861114370 (via script-0)
Total music tracks 31
(0:1:0x9): No items on stack to pop() for o72_talkActor
(0x6B) at [0-1]
(0:1:0x9): No items on stack to pop() for o72_talkActor
(0x6B) at [0-1]!

comment:11 by SF/iziku, 14 years ago

Just tried my freddi the fish and pajama sam games.

my copy of freddi is identifed as russian but is in english.
It also has the subtitle problem. It opens a debugger
console after the intro as soon as the door opens and the
whatever fish appears

"ERROR: (7:31:0xC): Invalid opcode 'f2' at c

I type exit and everything closes.

my copies of freddi3 and freddi4 and pajama list the
platform as default instead of windows. (I don't know how to
find the md5 so I can identify them for you).

I don't have pajama2...

comment:12 by Kirben, 14 years ago

I adjusted the HE version of balloon, so it should work.
The invalid opcode with freddi should be fixed too.

Please try the current Windows snapshot of ScummVM
and let us know the results.

Most HE games use the exact same data files for the
Macintosh and Windows versions, so it is normal that the
platform isn't always set to Windows under ScummVM.

comment:13 by SF/iziku, 14 years ago

balloon now works! :)

freddi still crashes and ignores the subtitle config
parameter . The crash happens as soon I have control of the
game. Same error message as before.

comment:14 by SF/iziku, 14 years ago

just noticed, balloon creates some files in the root of my drive

scummvmnames.bal
scummvmplayers.bal

are they supposed to be there or in the save/extra path? I
have both paths set to the scummvm dir.

comment:15 by Kirben, 14 years ago

I missed a spot with last change, freddi should work now.
Please try the current Windows snapshot of ScummVM and let
us know the results.

I'm not sure what would be causing the subtitle issue in
that version of freddi, please attach a debug level 9 log
of the game, until the first speech is played. ie
scummvm -d9 freddi > log.txt

ScummVM should write game data to the save path by default,
looks like a back slash in missing in those filenames
though. Will need to look into that issue more.

comment:16 by SF/iziku, 14 years ago

freddi crash is gone, attached is the log you requested for
the subtitle issue. This is just until seconds after the
first speech/subtitles appear.

by SF/iziku, 14 years ago

Attachment: log.zip added

freddi -d9 log (zipped)

comment:17 by Kirben, 14 years ago

The subtitles issue in freddi should hopefully be fixed
now, if not please attach aother log.
Please try the current Windows snapshot of ScummVM and let
us know the results.

comment:18 by SF/iziku, 14 years ago

freddi subtitles is fixed.

The issue with ballon files not being created in the save
folder remains.

many thanks :)

comment:19 by Kirben, 14 years ago

Could you please post the [scummvm] section of your
scummvm.ini file, which is usually stored in the Windows
directory. ie C:\WINDOWS

Also how did you set the save path in ScummVM? using the
GUI or by manually changing the scummvm.ini file?

comment:20 by SF/iziku, 14 years ago

I didn't edit the save path at all. (not in the gui, not in
the scummvm.ini manually). The path was set by scummvm
itself upon first execution. It apparently leaves a "\" off
the end when it does so and this is fine for most games
(they must check the path and automagically add the missing
\) but causes atleast balloon to put the saves in the wrong
place instead of the path shown. If I use the gui and
manually choose a path (even if it's the same one as chosen
by default) then the \ is added to the end and balloon puts
it's files in the correct location. They also get named
correctly - now that I think about it, that's why player.bal
and names.bal were coming up as scummvmplayer.bal and
scummvmnames.bal, my path was d:\scummvm, so the save was
put in d:\ and the name was scummvm+filename.

I can still post the contents of my scummvm file if you wish
but I'm pretty sure you don't need it now.

comment:21 by fingolfin, 14 years ago

Hm, yeah, indeed. The problem is likely caused by statements like this in
script_v72he.cpp, which blindly assume that a given path string ends with a
path delmiter, which they may not:

sprintf(filePath, "%s%s", _gameDataPath.c_str(), dst + r);
if (!Common::File::exists(filePath)) {
sprintf(filePath, "%s%s", _saveFileMan->getSavePath(), dst + r);
}

comment:22 by fingolfin, 14 years ago

Priority: normalhigh

comment:23 by fingolfin, 14 years ago

Summary: HE Games:Unknown versionsHE Games: Unknown versions

comment:24 by Kirben, 13 years ago

Resolution: fixed
Status: newclosed

comment:25 by Kirben, 13 years ago

The problems caused when saving a config file, when no save
path is set, is fixed in ScummVM SVN. Use the next daily
snapshot of ScummVM.

comment:26 by digitall, 11 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.