Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#2356 closed defect (fixed)

SIMON2WINTALKIE(ITA): Rate effect freeze

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

Version: Simon 2 Talkie (english) italian subtitles

Error: rate effect can only handle rates < 65536

Problem: freeze, impossible to continue

Ticket imported from: #1353408. Ticket imported from: bugs/2356.

Attachments (3)

simon 2 b.tiff (23.1 KB) - added by SF/*anonymous 14 years ago.
simon 2 cvs.tiff (32.4 KB) - added by SF/*anonymous 14 years ago.
Simon 2 cvs error
simon 1 cvs.tiff (31.7 KB) - added by SF/*anonymous 14 years ago.
simon 1 cvs error

Download all attachments as: .zip

Change History (29)

comment:1 Changed 14 years ago by (none)

Summary: SIMON2WINTALKIE: rate effect crashSIMON2WINTALKIE: rate effect freeze

comment:2 Changed 14 years ago by fingolfin

Status: newpending

comment:3 Changed 14 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 Changed 14 years ago by Kirben

Does ScummVM report an 'Unknown MD5' when you start
the game? please list the details if it does.

Does the game use English speech and Italian subtitles? or
Italian speech too?

comment:5 Changed 14 years ago by Kirben

Owner: set to Kirben
Status: pendingnew

comment:6 Changed 14 years ago by (none)

>>Does ScummVM report an 'Unknown MD5' when you start
the game? please list the details if it does.

No, or not in the debugger.. i don't know if there is a sort of log file..

>>Does the game use English speech and Italian subtitles? or
Italian speech too?

English speech, italian subtitles (italian speech doesn't exist).

comment:7 Changed 14 years ago by Kirben

The 'Unknown MD5' message would be shown in the console
window as ScummVM is started and not the debugger.

This problem is often caued by a corrupt speech file, could
you please provide the md5 checksum of your simon2.voc or
simon2.wav file.

comment:8 Changed 14 years ago by (none)

Yes, you have right, unknown md5... see the attached files

The simon2.wav md5 is:
aa665e68d738a36fa4a25ed1a76bf68e

Changed 14 years ago by SF/*anonymous

Attachment: simon 2 b.tiff added

comment:9 Changed 14 years ago by (none)

And the file to check for the right md5 is..?

comment:10 Changed 14 years ago by (none)

(the game works correctly on 0.6.1b; ok, but no sound on 0.7.1)

comment:11 Changed 14 years ago by Kirben

The problem should be fixed in the next ScummVM snapshot.

comment:12 Changed 14 years ago by (none)

I don't know if is important or not, because is a cvs however..

CVS 14 November (the first I have tryed)
Simon 2 is not found (see the attached screen)
The same error with Simon 1

Changed 14 years ago by SF/*anonymous

Attachment: simon 2 cvs.tiff added

Simon 2 cvs error

comment:13 Changed 14 years ago by Kirben

The game detection method of Simon engine was recently
changed, requiring details for all versions.

I added the details for the Italian version of Simon2, please try
the current Windows snapshot.

Is it the Italian version of Simon 1 too? or another language?
If you provide the details reported by ScummVM when you
start Simon 1, I will add those too.

comment:14 Changed 14 years ago by (none)

Ok then..

Simon 2: now see it, but always the rate effect error (identical)

Simon 1: yes, always the italian version (english speech, italian subtitles)
See attached screen for its "not found" error

Changed 14 years ago by SF/*anonymous

Attachment: simon 1 cvs.tiff added

simon 1 cvs error

comment:15 Changed 14 years ago by (none)

Summary: SIMON2WINTALKIE: rate effect freezeSIMON2WINTALKIE(ITA): rate effect freeze

comment:16 Changed 14 years ago by Kirben

Summary: SIMON2WINTALKIE(ITA): rate effect freezeSIMON2WINTALKIE: rate effect freeze

comment:17 Changed 14 years ago by Kirben

I added the details for the Italian version of Simon1.
I corrected the platform for the Italian version of Simon2.
Please try the current Windows snapshot.

Was the Italian version of Simon 2 an official release or fan
translation? as usually translations are based off the DOS
version. I thought the English and German releases were the
only Windows versions of games.

comment:18 Changed 14 years ago by (none)

Waiting for server bandwidth...

No, no.. a little story then.
In italy was released:
Simon 1 Dos Floppy - italian subtitles
Simon 2 Dos Floppy (i think) - italian subtitles
Simon 1 and 2 (together) Dos Talkie - english speech, italian subtitles

I'm talking about the last one. It has an horrible installer for win 95/98 (of
course on winxp don't work, with patches too) and two folders with Simon 1
Dos Talkie and Simon 2 Dos Talkie. I usually (at least on 0.6.1b) simply
set up this two folders in Scummvm and play them.

comment:19 Changed 14 years ago by (none)

Summary: SIMON2WINTALKIE: rate effect freezeSIMON2DOSTALKIE: rate effect freeze

comment:20 Changed 14 years ago by (none)

Then.. CVS 15 November 10:51

Simon 1: found, and seems to work well
Simon 2: found, and seems to work well (!)
(i thing the "separation" audio/subtitles was the question too, good idea)

However if you want a disc image, or same folders for testing purposes,
tell me
Thanks a lot ;-)

comment:21 Changed 14 years ago by (none)

Warning.. CVS 15 November 23:25 (4:38am)

Simon 1: don't charge backgrounds and characters
Simon 2: don't charge backgrounds and characters
Simon 2: No "Windows", are Dos Talkie versions (see the story in the
previous posts and excuse me for the wrong title)
Please revert to cvs 15 November 10:51 settings, was all ok

comment:22 Changed 14 years ago by (none)

Good.. CVS 16 November 18:10 (11:12pm)

Simon 1: found, and seems to work well
Simon 2: found, and seems to work well
Simon 2: not "It Windows CD", but "It DOS CD" (as Simon 1)

Thanks.

comment:23 Changed 14 years ago by Kirben

Resolution: fixed
Status: newclosed
Summary: SIMON2DOSTALKIE: rate effect freezeSIMON2WINTALKIE(ITA): Rate effect freeze

comment:24 Changed 14 years ago by Kirben

Thank you for the information about the Italian versions,
it was very helpful. I didn't know the WAV format of sound
was used in any DOS versions.

I had assumed this was a Windows version before, since it
used the WAV format for sound. I have corrected the game
title, use the current Windows snapshot.

The platform will still be set to Windows, since the
current sound code uses the platform setting to check sound
format required. I will improve the game detection settings
to solve this minor platform issue in the future.

comment:25 Changed 14 years ago by (none)

In the last CVS (Nov 16 2005 23:28) all right.
I understand (it's really a strange cd eheh),
thanks a lot to you too. Bye.

comment:26 Changed 12 years ago by Kirben

Component: Engine: AGIEngine: AGOS
Game: King's Quest 3Simon the Sorcerer 2
Note: See TracTickets for help on using tickets.