Opened 14 years ago

Closed 14 years ago

Last modified 7 months ago

#2350 closed defect (invalid)

ALL : F5 key randomly won't work

Reported by: SF/seyb Owned by: fingolfin
Priority: normal Component: Ports
Keywords: Cc:
Game:

Description

Most of the time, when I press the F5 key, the GUI menu won't
appear. As well, most of the shortcuts (ctr-1, etc...) are ineffective.

Powerbook G4 12" 1.33ghz, 10.4.3, ScummVM 0.8.0a

Am I the only one ?

Ticket imported from: #1351590. Ticket imported from: bugs/2350.

Change History (9)

comment:1 Changed 14 years ago by fingolfin

Works fine over here, on my PowerBook -- provided I press the FN key
together with the function keys (as by default, F5 changes the speaker
volume)...

Or did you change the function key setup in the system prefs? If so,
please state your precise configuration so that I can try to reproduce it...

comment:2 Changed 14 years ago by fingolfin

Owner: set to fingolfin

comment:3 Changed 14 years ago by SF/seyb

Well, I'm using an Apple bluetooth keyboard, so the F5 key is not used
(as far as I know) by any other programs.
I didn't change any function key in the Preference Panes, but I'm using
Xkeys which is an application to change the function keys uses (I'm
using F13 to launch Microsoft Messenger).

Sometimes, pressing F5 for a second or 2 will actually display the GUI
menu, but sometimes, even after pressing for 5 seconds, nothing will
come out.

This might be some kind of incompatibility with Xkeys or something.
Will try to find out on my own (by disabling Xkeys at first) if nobody has
this problem.

comment:4 Changed 14 years ago by fingolfin

Another use reported a similar issue under Windows.

Alas I am not sure those are the same issues, nor whether this is an
"issue" at all since I can't reproduce it and this is a first time I ever heard
of such a problem (which, given its annoyance factor, indicates that very
few people, if any, ever encountered the problem).

comment:5 Changed 14 years ago by fingolfin

Owner: fingolfin deleted
Summary: MAC : F5 key randomly won't workALL : F5 key randomly won't work

comment:6 Changed 14 years ago by SF/seyb

As I thought, Xkeys was the problem. I removed it and all the function keys are
fully working. Good to know. Thanks for your help anyway. :-) Keep up the good
work you guys !!

comment:7 Changed 14 years ago by fingolfin

OK, closing this then.

I got one other report from a Windows user with a similar problem, but since
several dozen / hundreds other people can't reproduce that one either, I am
pretty sure that he used some kind of customization software, too.

comment:8 Changed 14 years ago by fingolfin

Owner: set to fingolfin
Resolution: invalid
Status: newclosed

comment:9 Changed 7 months ago by digitall

Component: --Unset--Ports
Note: See TracTickets for help on using tickets.