Opened 14 years ago

Closed 14 years ago

#2348 closed defect (invalid)

LOOM TOWNS: doesnt work with scummvm 0.8.0

Reported by: SF/simon1o Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

hi
like the topics says its true, it doesnt work!
the floopy one too doesnt work. when i select the game
there shows a list up with games that are supported by
scummvm. but in this list isnt any loom. so i cant add
this game. ill tested my both loom versions with
scummvmversion 0.7.1 and in the list is loom added and
the game works. please fix this bug because ill tested
the version 0.8.0 for the psp and it doesnt work like the
pc version. so ill play with scummvm beta 4 for the psp
but loom has sound probelms with this version:(

thanks and props for this great software!

Ticket imported from: #1350655. Ticket imported from: bugs/2348.

Change History (8)

comment:1 by sev-, 14 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by eriktorbjorn, 14 years ago

I tried removing my scummvm.ini file and re-added both the
floppy and CD versions of Loom with the Windows version of
ScummVM 0.8.0. I didn't encounter any problems. In both
cases, the game was identified straight away as "Loom
(English (US)/DOS)", but of course you can edit the
description to tell the games apart.

It's strange that you were presented with a list of
different games. Do you keep the data files from several
games in the same directory? I imagine that might confuse
the game detection.

comment:3 by SF/freedidi, 14 years ago

I have the same problem with the FM towns version of loom
(loomTowns), the dos version worked fine for me.

When loomTowns is installed in a previous version of scummVM
(where it did still work) and started with 0.8.0 and above,
scummvm crashes with the following error message:
---
Looking for loomTowns
Trying to start game 'Obsolete Target'
WARNING: Target upgraded from loomTowns to loom!
Unknown MD5 (2d743ec88f43ec881662255389b56f29)! Please
report the details (language, platform, etc.) of this game
to the ScummVM team
The magic id doesn't match (0xFE03)!
---
the problem appeared with:

ScummVM versions 0.8.0 and 0.9.0CVS(Nov 9 2005)
Latest version known to work: 0.8.0CVS(Sep 13 2005) binary
shipped with SuSE 10.0
Game Version: Loom (FM Towns) (German)
Platform: Linux (Suse 10.0, kernel 2.6.13)
Compiler: "gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)"

Instructions: compile scummvm, run it, choose the directory
where loomTowns is saved.
Problem: a large list of games is shown, loom is not in
list, game can not be run.

thanks a lot!
:-)

comment:4 by fingolfin, 14 years ago

Summary: Loom doesnt work with scummvm 0.8.0!LOOM TOWNS: doesnt work with scummvm 0.8.0

comment:5 by fingolfin, 14 years ago

"Loom (FM Towns) (German)"

-> this a german version of Loom? If yes, it is a hacked/modified version and
we do not directly support it. You can use target_md5 to try to get it to work
anyway, though.

comment:6 by lordhoto, 14 years ago

look at this for help:
http://forums.scummvm.org/viewtopic.php?t=239

comment:7 by SF/joachimeberhard, 14 years ago

I really really really suspect this to be target_md5
business, since Loom CD and FMTOWNS have German
translations as well....

comment:8 by fingolfin, 14 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.