Opened 14 years ago

Closed 14 years ago

Last modified 11 months ago

#2335 closed defect (fixed)

ALL: Subtitle regression

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

With recent CVS snapshots, when loading an old
savegame, the game immediately shows some old garbage
subtitles; recognizable phrases, but which make little
or no sense in the context. I have only tried this with
Sam & Max and Monkey Island 2, but I imagine it affects
most or all games.

This is probably a regression from the recent subtitles
change cyx made. I notice that when loading a
pre-version 69 savegame, the _haveMsg variable is
always set to 0xFF, and _haveActorSpeechMsg will be
true in most cases, even if _haveMsg was 0. I assume
this has something to do with it.

I have not included any savegame here since I imagine
any 0.8.0 savegame will do, even if I haven't verified
this.

Ticket imported from: #1348080. Ticket imported from: bugs/2335.

Change History (6)

comment:1 by eriktorbjorn, 14 years ago

Owner: set to cyxx

comment:2 by Kirben, 14 years ago

Subtitle regressions should be fixed in old saved games now,
try again with current ScummVM CVS.

comment:3 by Kirben, 14 years ago

Owner: changed from cyxx to Kirben

comment:4 by eriktorbjorn, 14 years ago

Resolution: fixed
Status: newclosed

comment:5 by eriktorbjorn, 14 years ago

Seems to be working now, yes. Thanks!

comment:6 by digitall, 11 months ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.