Opened 14 years ago

Closed 14 years ago

#2334 closed defect (fixed)

FOTAQ: Wrong character in spanish version

Reported by: SF/kelmer Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

I am playing through Flight of the Amazon Queen
(spanish original CD version) using the latest stable
release (0.8.0) on the Win32 compilation, and found
that whenever a character asks a question the quazzy
mark (inverted question mark) is shown as a normal
question mark.

Every other character or symbols is shown correclty,
although the spanish "ń" seems to be too spaced
compared to the rest of the characters.

Attached is an screenshot showing the error.

Ticket imported from: #1348072. Ticket imported from: bugs/2334.

Attachments (2)

amazon.png (93.1 KB) - added by SF/kelmer 14 years ago.
queen_000.png (30.3 KB) - added by SF/kelmer 14 years ago.
shot with DosBox.

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by SF/kelmer

Attachment: amazon.png added

comment:1 Changed 14 years ago by SF/kelmer

Summary: Wrong character in spanish versionFOTAQ: Wrong character in spanish version

comment:2 Changed 14 years ago by cyxx

Probably a difference in the charset data of the spanish
version. Is it possible for you to run the game using the
original executable and attach a screenshot of the same
scene (I just want to be sure the problem is specific to
scummvm) ?
Thanks.

comment:3 Changed 14 years ago by SF/kelmer

There you go, strangely enough, the line is also shown
differently.

Changed 14 years ago by SF/kelmer

Attachment: queen_000.png added

shot with DosBox.

comment:4 Changed 14 years ago by cyxx

I committed some code to fix the quazzy question mark
character. You should be able to test with the next daily build.

Regarding the line endings, if I remember correctly, we
didn't use the same algorithm as the original.

About the spanish "" character, is it possible for you to
attach screenshots to see how different scummvm is from the
original ? Thanks.

comment:5 Changed 14 years ago by cyxx

Owner: set to cyxx

comment:6 Changed 14 years ago by SF/kelmer

I've just checked it and the problem with the "" (which I
found it to happen only occasionally) is also present in the
original interpreter.

comment:7 Changed 14 years ago by cyxx

Resolution: fixed
Status: newclosed

comment:8 Changed 14 years ago by cyxx

Thanks for checking.
Closing this item as quazzy mark should be fixed now.

Note: See TracTickets for help on using tickets.