Opened 14 years ago

Closed 14 years ago

Last modified 13 months ago

#2329 closed defect (invalid)

TABLETPC: Problems using Tablet PC with ScummVM

Reported by: SF/cromas Owned by: fingolfin
Priority: low Component: Port: Win32
Keywords: Cc:
Game:

Description

I own a Tablet PC, and I dreamt of playing SCUMM games
on it, which I thought would be the ultimate interface.
Unfortunately, the mouse-capturing system of ScummVM
appears to be completely incompatible with the way the
tablet digitizer reports cursor position. The cursor
goes absolutely nuts, jumping all over the screen,
usually to an edge or corner.

I theorize this is because ScummVM tracks relative
mouse movement, while the digitizer likely reports
absolute position, but I may be wrong. It also may have
to do with ScummVM running in less-than-full resolution.

It would be helpful if someone with a Wacom tablet
could see if this behavior is duplicated. I assume it
will be, as a Tablet PC essentially is just a Wacom
digitizer wedged under an LCD panel.

Could someone with more insight into how ScummVM tracks
mouse movement and/or how tablet digitizers report it
shed some light on this problem?

Ticket imported from: #1345461. Ticket imported from: bugs/2329.

Change History (15)

comment:1 by SF/joachimeberhard, 14 years ago

I have a TabletPC myself, and have the same problem.

The problem is, that the Wacom TabletPC Pointer driver only
works in the native screen resolution of the TabletPC.

The problem is, that when you run scummvm in fullscreen, it
sets the screen to a lesser resolution than the native
TabletPC resolution.

The pointer still works in window-mode, but the windows are
awfully small then, hence no fun to play.

Does the team know some workaround here, to set
ScummVM to a fixed resolution?

Best regards

Joachim Eberhard

comment:2 by SF/cromas, 14 years ago

Perhaps a 'native resolution' fullscreen mode could be
implemented where the graphics would just be scaled
ridiculously large.

comment:3 by SF/cromas, 14 years ago

Also, I'm not sure the resolution that ScummVM runs at is
necessarily the problem. My TabletPC comes with some
DOS-based diagnostic utlities, one of which tests the
digitizer. Cearly DOS is not running at 1024x768, but the
diagnostic software may be aware of that. It's hard to say,
but again, I'd like to hear from someone who knows about
ScummVM's interpretation of mouse movement and/or wacom's
reporting of it.

comment:4 by (none), 14 years ago

Tablet pointing device works fine outside full-screen
mode. Unfortunately it is not possible to resize this
windowed mode. Hope to see this bug fixed soon!

comment:5 by SF/joachimeberhard, 14 years ago

I still think that it could have something to do with
display resolution.

I have a HP tc1100 TabletPC with Geforce4Go 420 32MB.

I would figure, that the ScummVM games run in a resolution
of 640x480, which could lead to problems with the
DisplayDriver in conjuction with the Wacom digitizer
driver, because WindowsXP doesn't offer 640x480 as a
selectable Windows resolution anymore.

Regarding the digitizer in DOS:

My digitizer even works in the BIOS, but that's because HP
supports it, because the tc1100 is a convertible TabletPC
where you can detach the keyboard to make it ultraportable.

For over 1 month now, I only play my ScummVM games lying
on the couch with my Tablet, but unfortunately have to use
Window mode.

I would hope to see this bug fixed soon also, since there
are quite a few TabletPCs out there, growing even more,
since Vista will incorporate the TabletPC functionallity
into every Vista Edition, even the Home Edition.....

comment:6 by fingolfin, 14 years ago

Priority: normallow
Status: newpending
Summary: SCUMMVM incompatible with Tablet pointing deviceTABLETPC: Problems using Tablet PC with ScummVM

comment:7 by fingolfin, 14 years ago

This all doesn't sound like a bug in ScummVM itself at all. It's either a bug in
your table driver, or *maybe* in SDL (in which case you should bug the SDL
folks). There is nothing in ScummVM which is special about the way we
handle mouse coordinates, so it's very unlikely that we are causing this bug.

Please test some other full screen SDL games, make sure your drivers are the
latest, etc.. Also please comply to our bug submission guidelines (which,
besides other things, explicitly asks for the ScummVM version, the OS and its
version and other things).

comment:8 by SF/sf-robot, 14 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:9 by SF/sf-robot, 14 years ago

Status: pendingclosed

comment:10 by SF/cromas, 14 years ago

Reopening after some further research --

You were right, this isn't a ScummVM bug, but a sideffect of
how the built-in tablet digitizer drivers interpret pen
coordinates in a non-native screen resolution. Nobody I
talked to at Wacom seemed too interested in fixing this. Re:
my comment on 11/23/05, I believe a full-screen,
native-resolution feature in ScummVM would workaround this
problem. Any possibility of this being written?

comment:11 by SF/cromas, 14 years ago

Status: closednew

comment:12 by fingolfin, 14 years ago

Resolution: invalid
Status: newclosed

comment:13 by fingolfin, 14 years ago

You can file a feature request for this if you like (though I think there is already
one, in which case you might want to comment).

Still, this isn't a bug in ScummVM :-).

comment:14 by fingolfin, 14 years ago

Owner: set to fingolfin

comment:15 by digitall, 13 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.