Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2321 closed defect (fixed)

BASS CD: Italian accented char doesn't visualize correctly

Reported by: SF/licantrop0 Owned by: eriktorbjorn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

The Italian accented charter like "ŕ, č, ě, ň, ů" doesn't visualized correctly in Beneath a Steel Sky game CD VERSION. The floppy version works correctly.

The correct sentence in the attached file is: "Non č di alcuna utilitŕ."

what can I do?

Ticket imported from: #1344068. Ticket imported from: bugs/2321.

Attachments (1)

bass Ita.JPG (50.3 KB ) - added by SF/licantrop0 14 years ago.
screens of the bug

Download all attachments as: .zip

Change History (6)

by SF/licantrop0, 14 years ago

Attachment: bass Ita.JPG added

screens of the bug

comment:1 by eriktorbjorn, 14 years ago

We do make a lot of adjustments to the BASS character set, but in this case my guess would be that it's a bug in that particular string. I can reproduce it in BASS v0.0368 (the freeware talkie version), but not in BASS v0.0372 (another talkie version I bought on eBay, but which is not freeware).

BASS uses a non-standard character encoding, but in the newer CD version the string is "Non ] di alcuna utilit." In the older one, it's "Non _ di alcuna utilit_." i.e. both accented characters appear to be the same, although they should be different.

It would be possible to use the patchMessage() mechanism to replace the faulty message (this one is number 4545), but if it's more than just that one message it could be a lot of work. The guard's first line when he notices you forcing the door at the beginning is different in the two versions, so it doesn't look like an isolated occurence.

Another possibility is that there's an error in _huffTree_00368[], but that seems less likely to me.

comment:2 by joostp, 14 years ago

As eriktorbjorn said, the CD version we offered for download wasn't the most recent known BASS versions, and contained some localisation bugs.

As you can see by the news item on the front page, we've updated the data files to the most recent version. Can you check if the problem is 'solved' with this new version?

comment:3 by SF/licantrop0, 14 years ago

YESSSS!!! now it works perfectly!

You are great, guys!!! Thank you!!!!

comment:4 by eriktorbjorn, 14 years ago

Closing this bug report, then. While the older version still isn't fixed, of course, it's not a ScummVM bug.

comment:5 by eriktorbjorn, 14 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.