Opened 14 years ago

Closed 9 years ago

Last modified 9 years ago

#2317 closed defect (fixed)

FM-TOWNS: Kanji rendering glitches

Reported by: SF/doc_wagon Owned by: athrxx
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

The japanese version of Loom (FMTowns) shows text
rendering glitches.
See attached screenshot and/or this post:
http://forums.scummvm.org/viewtopic.php?p=72

Since the font is hardcoded in the ROM file and fixed
at 16x16 pixels, IMHO there's only 2 possibilities of
what's going wrong there:
1) the text needs to be wrapped at the end of the line,
but it isn't (or it is wrongly wrapped)
2) the characters are spaced too far (I think they
could be moved closer by 1 pixel, but I doubt that
would be enough to make room for all of them)

Ticket imported from: #1342836. Ticket imported from: bugs/2317.

Attachments (1)

scummvm_kanji_bug.png (21.4 KB ) - added by SF/doc_wagon 14 years ago.
screenshot of text rendering bug

Download all attachments as: .zip

Change History (17)

by SF/doc_wagon, 14 years ago

Attachment: scummvm_kanji_bug.png added

screenshot of text rendering bug

comment:1 by SF/doc_wagon, 14 years ago

Forgot to mention: I'm using ScummVM 0.9.0CVS from today
(Oct 30 2005)

comment:2 by SF/kaminari, 14 years ago

3) it's not a bug, it's a lack of feature (the original
FM-Towns version uses a 640x480 overlay for the rendering of
kanjis)

http://namida.com/kaminarimon/tmp/indy4fmt_01a.png

comment:3 by Kirben, 14 years ago

Summary: LOOM FMTOWNS Kanji text rendering glitchFMTOWNS Games: Kanji rendering glitches

comment:4 by fingolfin, 14 years ago

Summary: FMTOWNS Games: Kanji rendering glitchesFM-TOWNS: Kanji rendering glitches

comment:5 by fingolfin, 14 years ago

See also bug #1340587.

comment:6 by sev-, 13 years ago

Priority: normallow

comment:7 by sev-, 13 years ago

lowering priority.

comment:8 by sev-, 11 years ago

Owner: set to sev-

comment:9 by fingolfin, 9 years ago

Florian, do your recent changes maybe address this bug report, too?

comment:10 by fingolfin, 9 years ago

Owner: changed from sev- to athrxx

comment:11 by athrxx, 9 years ago

This seems to be bug report from times when we did not even have the necessary 2x scaling. But the font rendering (spacing etc.) is still not accurate.

My recent changes slightly improved CJK mode. I'll start working on this some more since I am now done with Indy 4 / Monkey 2 sound effects.

comment:12 by athrxx, 9 years ago

I did some more work on the Japanese font rendering. This should be accurate in all situations now. We even have overhead font drawing for the circus scene in Monkey Island 1 after Guybrush gets shot out of the cannon.

Please test again. I set this item to pending.

Florian

comment:13 by athrxx, 9 years ago

Resolution: fixed

comment:14 by athrxx, 9 years ago

Status: newpending

comment:15 by SF/sf-robot, 9 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:16 by SF/sf-robot, 9 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.