Opened 14 years ago

Closed 11 years ago

Last modified 13 months ago

#2314 closed defect (fixed)

FM-TOWNS: Kanji crashes with FONTROM

Reported by: SF/joachimeberhard Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

MonkeyTowns crashes since CVS 10/23/2005 with
language=jp if FONT-ROM is installed.

For CVS 10/27/2005 it is no longer possible to start the
game with Kanji-Fonts.

It crashes WITHOUT ERROR!!!

Best regards

Joachim Eberhard

Ticket imported from: #1340587. Ticket imported from: bugs/2314.

Change History (10)

comment:1 by fingolfin, 14 years ago

Summary: MonkeyTowns Kanji crashes with FONTROMMItowns: Kanji crashes with FONTROM

comment:2 by SF/joachimeberhard, 14 years ago

To clarify my statement from above:

Kanji worked perfect in CVS 10/23/2005, but wth the next
CVS I tested 10/27/2005, and in the 0.8.0 Final, most Kanji
Games crash with Kanji-Rom enabled.

This is a very sad regression intorduced a few day before the
final version and you couldn't fix anymore for 0.8.0 Final.

Best regards

Joachim

comment:3 by Kirben, 14 years ago

Please try the old ScummVM versions I put online at
http://members.optusnet.com.au/wormmon/test/ to help track
down when exactly this regression occured.

comment:4 by fingolfin, 14 years ago

Closed #1340580 as a duplicate of this, renaming the bug to show that it is
generic.

The crash occurs at the very least in INDY4 and Monkey (both for FM-TOWNS, of
course).

comment:5 by fingolfin, 14 years ago

Summary: MItowns: Kanji crashes with FONTROMFM-TOWNS: Kanji crashes with FONTROM

comment:6 by fingolfin, 14 years ago

See also bug #1342836.

comment:7 by sev-, 11 years ago

Owner: set to sev-

comment:8 by sev-, 11 years ago

Resolution: fixed
Status: newclosed

comment:9 by sev-, 11 years ago

Now it does not crash, and Kanji is rendered, though the position is not yet correct and text plane is not cleared properly. At least this bug could be closed.

comment:10 by digitall, 13 months ago

Component: Engine: SCUMM
Game: Monkey Island 1
Note: See TracTickets for help on using tickets.