Opened 14 years ago

Closed 8 years ago

Last modified 8 years ago

#2308 closed defect (fixed)

ITE: Odd Sound in Tychos House (XMIDI/MT-32 related?)

Reported by: SF/rakani_firedorn Owned by:
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM v0.8.0pre

When in Tychos house on the hill, there seems to be an
odd noise intermitently at a louder volume than the
rest of the sfx/speech. I have thought it might be the
sound of him puffing on his pipe, but I don't recall
ever hearing it in the original.

It seems out of place/a bug as it clearly drowns out
the game conversation speech when it happens so miss
some of the dialogue.

English CD Talkie version
Win32 running on WinXP Pro

Ticket imported from: #1336434. Ticket imported from: bugs/2308.

Attachments (2)

ite.s00 (3.8 KB ) - added by SF/rakani_firedorn 14 years ago.
Save at location of odd sound
ite.s03 (4.7 KB ) - added by SF/rakani_firedorn 14 years ago.
Odd sound in cottage

Download all attachments as: .zip

Change History (21)

by SF/rakani_firedorn, 14 years ago

Attachment: ite.s00 added

Save at location of odd sound

comment:1 by SF/rakani_firedorn, 14 years ago

Summary: Odd Sound in Tychos HouseITE: Odd Sound in Tychos House

comment:2 by sev-, 14 years ago

Which sound driver in ScummVM are you running? Adlib or MT-32?

comment:3 by sev-, 14 years ago

Owner: set to sev-

comment:4 by SF/rakani_firedorn, 14 years ago

Windows MIDI actually

by SF/rakani_firedorn, 14 years ago

Attachment: ite.s03 added

Odd sound in cottage

comment:5 by SF/rakani_firedorn, 14 years ago

I have found the same SFX problem in another location:
Elara's sisters cottage in the wild lands.

Save game attached

comment:6 by eriktorbjorn, 14 years ago

I don't have the original CD release, but I can reproduce it
under Windows with the WyrmKeep release, if I force it to
use the original XMIDI music instead of the standalone MIDI
file or the digitized music.

I don't get the hissing sound with the Adlib driver, though.

comment:7 by eriktorbjorn, 14 years ago

If I understand the MIDI messages correctly, it a couple of
notes on channel 0, using MIDI instrument 126, which would
be... "Applause"?

I'm not sure which instrument it should be, though. It's
played loud enough that it's pretty obnoxious no matter
which one I tried.

comment:8 by sev-, 14 years ago

Native Windows MIDI together with ScummVM XMIDI parser make
an acid combination I think. Unfortunately it's out of my
scope, as I don't have proper dev tools on Windows machine.
Eriktorbjorn. may you take a look at it?

comment:9 by sev-, 14 years ago

Owner: sev- removed

comment:10 by eriktorbjorn, 14 years ago

Well, the problem should manifest itself even on other
operating systems, assuming you can play MIDI at all on
them. I just haven't tried it on anything else yet.

I'm afraid I've pretty much exhausted my knowledge of MIDI,
though.

comment:11 by SF/rakani_firedorn, 14 years ago

I tried running in MT-32 but it wouldnt even run at all
crashed upon running the game.

Adlib works but the music is too artificial sounding for my
liking.

comment:12 by SF/rakani_firedorn, 14 years ago

Request ID 1313512 seems to point to this happening in MT-32
as well even though I cannot get it running under that.

comment:13 by SF/jellby, 14 years ago

I experienced the same problem with a current SVN build
(2006-04-30) under linux. With the MT32 emulator I get an
annoying noise, with fluidsynth I couldn't hear anything
strange. I could be able to test it with a real MT32, but
that would have to wait several weeks.

comment:14 by fingolfin, 13 years ago

So this sounds as if this issue is caused by a "bad" MIDI instrument mapping? This would at least explain why it occurs in some MIDI setups and not in others -- the GM standard only describes which instruments are which, but not how precisely they should sound, and the MT-32 of course is different yet again.

comment:15 by fingolfin, 12 years ago

Summary: ITE: Odd Sound in Tychos HouseITE: Odd Sound in Tychos House (XMIDI/MT-32 related?)

comment:16 by raziel-, 10 years ago

It seems @jellby wasn't able to get back with a report for a real MT-32.
I can *not* confirm this issue with a real MT-32. I don't even remotely hear an odd sound, let alone one that disturbs speech/music.

Hope it helps to corner that bug

comment:17 by bluegr, 8 years ago

Resolution: fixed
Status: newclosed

comment:18 by bluegr, 8 years ago

This no longer occurs with the latest version of munt

Closing as fixed

comment:19 by bluegr, 8 years ago

Addendum: This occurred in scene 33

Note: See TracTickets for help on using tickets.