Opened 14 years ago

Closed 3 years ago

#2285 closed defect (fixed)

ZAKV1 C64 Caponians dont disguise after using blue crystal

Reported by: SF/joachimeberhard Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Tested with CVS 10/16/2005 on Win32

This bug appears in V1 Classic DOS & C64 using CVS!
This bug does NOT happen in DOSBox.

When using the blue crystal on any animal, in the
cutscene the caponians put on hat and noseglasses.
However they are NOT wearing a hat and noseglasses
when they appear on site looking for you.

This bug does NOT happen in DOSBox.

Best regards

Joachim Eberhard

Ticket imported from: #1329542. Ticket imported from: bugs/2285.

Attachments (1)

zak.s17 (7.1 KB) - added by SF/joachimeberhard 13 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by Kirben

Please test again, with a recent ScummVM snapshot, as I'm
unable to reproduce the issue.

comment:2 Changed 13 years ago by Kirben

Status: newpending

Changed 13 years ago by SF/joachimeberhard

Attachment: zak.s17 added

comment:3 Changed 13 years ago by SF/joachimeberhard

Status: pendingnew

comment:4 Changed 13 years ago by SF/joachimeberhard

Great work, in all situations except with after the
dolphin, the issue is gone.

savegame attached

comment:5 Changed 13 years ago by Kirben

Summary: ZAKV1 Caponians dont disguise after using blue crystalZAKV1 C64 Caponians dont disguise after using blue crystal

comment:6 Changed 12 years ago by fingolfin

What is the status of this item?

comment:7 Changed 12 years ago by Kirben

The problem still occurs, the caponian appears without the hat and nose glasses, after using the blue crystal on the dolphin.

comment:8 Changed 10 years ago by (none)

I tested ZAK-V1-DOS / English on Win32 with

ScummVM 1.0.0rc143718 (Aug 25 2009 12:34:25)
Features compiled in: Vorbis FLAC MP3 zLib FluidSynth

and did not see this bug. Maybe it's fixed and can be closed?

comment:9 Changed 3 years ago by segrax

This bug still exists and can be replicated by

  1. Use the blue crystal on bird/dolphin
  2. Visit The King (make sure you show him your fan club card)
  3. Use the blue crystal on bird/dolphin

Scripts:

The cut scene (script-96) inside the telephone company which triggers just after first using the crystal, sets Var[245] (Actor 7's Costume) to 0x1C (Disguise On) and locks object 344. This cut scene is not played again.

When you fly to the Bermuda Triangle and abducted, you can ring the door bell... this sets Var[245] back to 0x18 (Disguise Off). The previous variable state is not stored, and thus not restored upon leaving the craft.

When you use the blue crystal again, object 344 being locked prevents script 96 from being started, thus Var[245] is not changed.

You can also visit the telephone company to set Var[245] to 0x1C (Disguise on)

comment:10 Changed 3 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

Is it the winner? 11 years before segrax nailed it down. Fixed.

Note: See TracTickets for help on using tickets.