Opened 14 years ago

Closed 14 years ago

#2281 closed defect (invalid)

ZAKV1 Plane on background of airport isn't always displayed

Reported by: SF/joachimeberhard Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Tested with CVS 10/16/2005 on Win32

This bug appears in V1 Classic DOS & C64 using CVS!
This bug ALSO happens in DOSBox.

When entering any airport, the chance is almost 1:1
that the plane in the background isn't drawn.
The background is just pale blue then.
Just exit the airport & enter again, chances are now 1:1
again the plane is displayed.

This seems to be a bug of all V1 Versions, since I was
able to reproduce it with all 2 reported V1 DOS Versions
using DOSBox. And it also happens in ScummVM for
both DOS & C64 versions.

Best regards

Joachim Eberhard

Ticket imported from: #1329491. Ticket imported from: bugs/2281.

Change History (2)

comment:1 by Kirben, 14 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:2 by Kirben, 14 years ago

This occurs in all versions of zak and isn't a bug, since it
occurs in the original game.

Sounds like the programmers choose to show the plane in
the background at random in the airports, to give the
locations some variety.

Note: See TracTickets for help on using tickets.