Opened 14 years ago

Closed 12 years ago

Last modified 8 months ago

#2279 closed defect (worksforme)

ZAKV1 Stewardess stuck if called after egg-explosion

Reported by: SF/joachimeberhard Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Tested with CVS 10/16/2005 on Win32

This bug appears in V1 Classic DOS & C64 using CVS!
This bug does not happen in DOSBox.

After overflowing the sink and exploding the egg in the
microwave, overflow the sink again and push the call
button. The stewardess will come after some time.

In DOSBox she says "Please sit down", you walk to
your seat, and she starts cleaning the mess.

In ScummVM, she is stuck in the door.
You can "unstick" her by opening a bin.
She will guide you to your seat, and then is stuck again
there. She won't move a bit.

Best regards

Joachim Eberhard

Ticket imported from: #1329465. Ticket imported from: bugs/2279.

Attachments (2)

zak.s02 (6.7 KB) - added by SF/joachimeberhard 13 years ago.
zak.s03 (6.9 KB) - added by SF/joachimeberhard 13 years ago.

Download all attachments as: .zip

Change History (11)

Changed 13 years ago by SF/joachimeberhard

Attachment: zak.s02 added

comment:1 Changed 13 years ago by SF/joachimeberhard

attached savegames

Changed 13 years ago by SF/joachimeberhard

Attachment: zak.s03 added

comment:2 Changed 13 years ago by SF/joachimeberhard

second save

comment:3 Changed 12 years ago by fingolfin

Hm, I can't seem to open these savegames, neither with current SVN nor with 0.9.0. ScummVM just errors out. Looking at the debug output, it says:

You have 7020931d5a2be0a49d68e7a1882363e4 and save is 35183fc18b1e04cdc9070078260b2c03.

The latter Md5 is unknown to me. What version of Zak is that, I wonder?

comment:4 Changed 12 years ago by fingolfin

According to Kirben, these saved games might have been made with the C64 version of the game (which I don't have, so I can't use them).
Since this scene occurs early in the game, I just tried to play to it myself. However, I can't seem to reproduce it. Specifically, after exploding the egg, i can press the call button as often as I wish -- the stewardess never returns :-/. Maybe I am missing something?

It might help to attach a savegame made with the DOS V1, from which one can reproduce this ideally with a single click (i.e. pushing the button). After all, it's difficult to fix bugs one can't reproduce :)

comment:5 Changed 12 years ago by fingolfin

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:6 Changed 12 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newpending

comment:7 Changed 12 years ago by SF/sf-robot

Status: pendingclosed

comment:8 Changed 12 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:9 Changed 8 months ago by digitall

Component: Engine: SCUMM
Game: Zak McKracken
Note: See TracTickets for help on using tickets.