Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2270 closed defect (fixed)

MANIACNES: Shortcut keys are incorrectly configured

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Start the game from scratch. Select kids and skip the
intro. Press F5 and look at the help for the "Main
game controls". It claims that the keys are logically
oriented, that Q is Push, A is Pull, and Z is give.

Press Q. You'll select the Push verb. Press A.
You'll be selecting the Close verb, not the Pull verb
as documented (and as would make sense here). Press T.
Now you've selected Pull. Press Z. You'll select
Read, because Give and Goto are, illogically, F and G
respectively.

And, of course, none of the inventory hotkeys work, as
documented.

I'm testing on Windows 2000, using Maniac NES (English
US), ScummVM 0.8.0CVS (Oct 15 2005 21:10:23), Features
compiled in: Vorbis FLAC MP3 zLib MPEG2

Ticket imported from: #1328146. Ticket imported from: bugs/2270.

Change History (6)

comment:1 by sev-, 14 years ago

Owner: set to sev-

comment:2 by sev-, 14 years ago

Heh, good hit. Will do it soon

comment:3 by sev-, 14 years ago

Hmmm... (a) no time (b) it appeared to be not so trivial.
Back to the pool for now.

comment:4 by sev-, 14 years ago

Owner: sev- removed

comment:5 by fingolfin, 13 years ago

The problem is that we assign the hotkey in o2_verbOps under the assumption that there are 5 verbs per row, but in MM NES there are only 4.

Fixed in SVN. Existing savegames will still have "wrong" shortcuts assigned until you use New Kid to switch to another kid (forcing a reset of the verbs).

comment:6 by fingolfin, 13 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.