Opened 14 years ago

Closed 12 years ago

Last modified 5 months ago

#2223 closed defect (fixed)

MT32/IHNM: scratching sound on right channel

Reported by: SF/realwintermute Owned by: sev-
Priority: low Component: Audio: MT32
Keywords: Cc:
Game: I Have No Mouth

Description

When the title appears (IHNM) the music starts to make
scratching sounds on the right stereo channel.

Soundblaster Audigy 2 ZS
i925X Chipset
PIV 640 (Prescott, 3,2Ghz)

Ticket imported from: #1313509. Ticket imported from: bugs/2223.

Attachments (1)

test3.wav (229.5 KB) - added by SF/realwintermute 14 years ago.
Example

Download all attachments as: .zip

Change History (12)

comment:1 Changed 14 years ago by eriktorbjorn

I can't reproduce this on either of the two computers I've
tried it on. For what it's worth, I believe all it does at
this point is to play MIDI (or Adlib) music, so there
shouldn't be any other sound effects going on.

(Once the "hate" speech begins, there is a crackling
background noise, but I think that's on both channels, and
it should be there.)

Changed 14 years ago by SF/realwintermute

Attachment: test3.wav added

Example

comment:2 Changed 14 years ago by SF/realwintermute

i use the CVS btw (forgot to write that before)
the problem only occurs with MT32 emu (as the MT32 emu
makes some strange things in ITE, too)

I recorded an example. Strangely it seems to appear in the
recording on both channel and isn't that audible as it is when
played directly. I think i have to blame the crative drivers for
this or the M$ audiorecorder (yeah, it might be crap but it was
at hand ;) )

comment:3 Changed 14 years ago by eriktorbjorn

Ah, I didn't realize this bug report was about the MT-32
emulator as well. I'm afraid I don't have any experience
with that one. I don't have an MT-32, so I don't have the
necessary data files, and my computer is too slow to run it
anyway.

I think IHNM uses General MIDI, in which case the MT-32
emulator may not be the best choice for it.

By the way, in case you're interested, there are two
low-quality MP3s from the IHNM score on the composer's own
Web page:
http://www.johnottman.com/projects/miscprojects/ihavenomouth/index.html

comment:4 Changed 14 years ago by sev-

Also it may happen that now we even play wrong music track
(FM instead of GM or vice versa). Lowering priority.

comment:5 Changed 14 years ago by sev-

Priority: normallow

comment:6 Changed 13 years ago by fingolfin

If the problem only occurs when using the MT-32 emulator -- shouldn't it be
turned into a bug against that instead (i.e. it can stay in this tracker, but the
summary could be changed to reflect this...)

comment:7 Changed 12 years ago by fingolfin

Summary: IHNM: scratching sound on right channel while playing introMT32/IHNM: scratching sound on right channel

comment:8 Changed 12 years ago by bluegr

I can't reproduce this with the current SVN, using the MT-32 emulator. I'm running ScummVM under Windows Vista 32-bit, and my soundcard is an on-board Realtek soundcard

Can someone else verify that this is still occuring?

comment:9 Changed 12 years ago by sev-

Yes, apparently it was fixed with Munt update

comment:10 Changed 12 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:11 Changed 5 months ago by digitall

Component: Audio: MT32
Game: I Have No Mouth
Note: See TracTickets for help on using tickets.