Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2217 closed defect (invalid)

MONKEY2 FMTOWNS crashes at start in current 0.8.0CVS

Reported by: SF/joachimeberhard Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Version of Game: MONKEY2 FMTOWNS ENGLISH on
ScummVM0.8.0CVS on Win32.

This has been the case since i first tested CVS from the
beginning of August and is still present in latest CVS,
its only recently i managed to file a bug report.

Maybe those bugs have something to do with the
removed targets.

Nothing much to say, game crashes after selection
MONKEY2/MONKEY2LITE directly in the beginning.

Error: Unknown Screen Effect, 30

Well its easy to reproduce, isn't it?

Hope you fix it soon along with ZAKTOWNS, before the
Release of 0.8.0! You should generally concentrate
again more on ScummGames I think. As far as I'm
concerned, you shouldn't release 0.8.0 all to soon, still
seems very buggy, you could disappoint some
LucasArts Fans with this release.

Best regards

Joachim

Ticket imported from: #1309455. Ticket imported from: bugs/2217.

Change History (9)

comment:1 Changed 14 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:2 Changed 14 years ago by Kirben

Set the platform to FM-TOWNS for the game.

comment:3 Changed 14 years ago by Kirben

Resolution: invalidfixed

comment:4 Changed 14 years ago by Kirben

Oops I didn't notice there was no default case for that function
earlier, so there actually was a missing case.
Fixed in ScummVM CVS and I just updated the ScummVM
0.8.0 CVS snapshot for Windows too.

comment:5 Changed 14 years ago by SF/joachimeberhard

Sorry kirben, but the platform IS set to FMTOWNS.

I have tested it with ScummVM071 also, works perfectly.

And I also have the original MONEY2CD, with the exact
matching MD5.

I have tested the same bug on other machines, but only for
WIN32.

Please test again.

I am willing to donate 20 for resolving this bug!

Hope you will fix.

Bye

Joachim

comment:6 Changed 14 years ago by SF/joachimeberhard

Resolution: fixedinvalid

comment:7 Changed 14 years ago by SF/joachimeberhard

See? I donated 20 Bucks!

Thanks alot for fixing this!

Works like a charm now in Current CVS!

Thanks a lot, but don't forget abou ZAKTOWNS!

See ya

Joachim

comment:8 Changed 14 years ago by sev-

So may you test it now with daily snapshot?

comment:9 Changed 14 years ago by SF/joachimeberhard

Yes, since kirben fixed this bug, I can now play MI2TOWNS.

Shall I file you, if it is completable?

Also, i would like to test other games for completion, if you
like, Just post me what to do exactly.

See ya, Joachim

@sev: Please think of the demos I asked you about a week
ago. Thanks!

Note: See TracTickets for help on using tickets.