Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2215 closed defect (fixed)

FOA: skips single line of dialogue

Reported by: SF/dogmatixman Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Very minor bug in the English Talkie version of Indiana
Jones and the Fate of Atlantis. A line of audio
dialogue is skipped, but the subtitles for the line
appear for a very short period of time.

The skipped line ("There are two orichalcum beads in
these bones!") occurs when Indiana looks at some bones
in Crete for the first time, on the Wits path. I have
not checked if this also occurs in the original
interpreter.

ScummVM version: Originally found when playing in
ScummVM 0.7.1 (Mar 27 2005 10:51:21) -- official
release, with the same problem occuring when tested in
ScummVM 0.8.0CVS (Sep 29 2005 19:57:54) -- win32
nightly release.

0.7.1 savegame is attached (at a point just before the
problem occurs).

I expect only perfectionists will care about this one :)

Ticket imported from: #1308033. Ticket imported from: bugs/2215.

Attachments (2)

atlantis.s05 (16.3 KB ) - added by SF/dogmatixman 14 years ago.
savegame ("Look at some bones" to trigger the bug)
atlantis.s04 (16.9 KB ) - added by SF/dogmatixman 14 years ago.
Before placing beads in the box ("Look at some bones" to trigger the line)

Download all attachments as: .zip

Change History (11)

by SF/dogmatixman, 14 years ago

Attachment: atlantis.s05 added

savegame ("Look at some bones" to trigger the bug)

comment:1 by eriktorbjorn, 14 years ago

My guess would be a bug in the original game, though I
haven't verified that. I think it starts to speak the "There
are two ..." line, but doesn't wait for it to finish before
speaking the next line.

I wonder what'd happen if you examine the skeleton before
putting the first bead in the box...

by SF/dogmatixman, 14 years ago

Attachment: atlantis.s04 added

Before placing beads in the box ("Look at some bones" to trigger the line)

comment:2 by SF/dogmatixman, 14 years ago

I had a savegame that allowed me to check this very easily,
and your suspicion was right: when you haven't placed any
beads in the box yet, it plays the line properly.

Savegame attached. Same deal to trigger the line ("Look at
some bones").

comment:3 by sev-, 14 years ago

Can anyone test it with original under dosbox?

comment:4 by fingolfin, 14 years ago

I wonder if there is a bootparam close by, then testing it with some help by
dosbox should be easy...

comment:5 by fingolfin, 14 years ago

Priority: normallow

comment:6 by fingolfin, 14 years ago

Assuming the bug is present in the original, and hence a
script bug, we might be able to add a workaround, by
checking for the correct spot in the script and inserting a
"wait for message". Doing that for the english version only
would be relatively easy, because we could just check for
the text.

But I wonder whether this also occurs in localized versions
of the game, and if yes, whether we can do something about
it.

I have the german version of FOA but I am too lazy to play
until that spot, so knowing a close-by bootparam gets more
and more attractive *g*.

comment:7 by fingolfin, 14 years ago

Status: newclosed

comment:8 by fingolfin, 14 years ago

It turns out that the problem can be reproduce by simply "beaming" straight to
room 160.

So I added a fix to CVS which works fine for me in both english & german FOA.

comment:9 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: fixed
Note: See TracTickets for help on using tickets.