Opened 14 years ago

Closed 14 years ago

#2206 closed defect (fixed)

COMI: Music glitch at beginning of part 2

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Latest ScummVM CVS snapshot (it's not a regression, though)
English CoMI

At the beginning of part 2 of the game, when Guybrush
finds that Elaine has been turned into a gold statue,
just around the time he says that "She's not going to
be happy about this." the music plays a brief harp
passage, and then it fades out. It's not supposed to
fade out, it's supposed to keep playing.

The culprit appears to be this opcode, near the end of
script-141: soundKludge([4096,4]). This is translated
into a call to setComiMusicState(4), but it's
apparently not a valid music state since they are all
numbered 1000 or greater. ScummVM currently maps it to
music state 1000, which is the "null" state where music
is turned off.

Apparently it's supposed to do something entirely
different, but I'm not sure what. The script ends like
this:

[01DF] (85) endOverride()
[01E0] (8D) actorFollowCamera(VAR_EGO)
[01E6] (82) endCutscene()
[01E7] (B2) soundKludge([4096,4])
[01F7] (79) startScript(1,206,[])
[0207] (65) if (bitvar65) {
[0211] (89) setClassOf?(396,[32])
[0221] (**) }
[0221] (7B) stopObjectCode()
END

Ticket imported from: #1294660. Ticket imported from: bugs/2206.

Attachments (1)

comi.s01 (67.7 KB ) - added by eriktorbjorn 14 years ago.
Savegame at the end of part 1

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 14 years ago

Attachment: comi.s01 added

Savegame at the end of part 1

comment:1 by eriktorbjorn, 14 years ago

Owner: set to aquadran

comment:2 by aquadran, 14 years ago

i know about state 4, it's a trash(transition from the dig)
from original development of game. and it's only one such
thing. so if should be interpreted as not change current
song, so feel free change code to ignore state like 'if
(state == 4) return'

comment:3 by eriktorbjorn, 14 years ago

Owner: changed from aquadran to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:4 by eriktorbjorn, 14 years ago

Ok, I've done that. Thanks for looking at it.

Note: See TracTickets for help on using tickets.