Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2204 closed defect (fixed)

FOA/Amiga: Palette problem (Regression)

Reported by: SF/ceztko Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

In this room there's a evident palette problem. I took
a screenshot with UAE. Observing more carefully,
there's A LOT of microdifferences between the raw
bitmap taken within UAE and the scummvm screenshot, but
I could be happy anyway if this macro-one is solved :-)

Thanks, ceztko

Ticket imported from: #1294513. Ticket imported from: bugs/2204.

Attachments (3)

i4-scummvm.png (27.3 KB) - added by SF/ceztko 14 years ago.
Indy 4 - scummvm
i4-UAE.png (26.8 KB) - added by SF/ceztko 14 years ago.
Indy 4 - UAE
diff.txt (8.7 KB) - added by Kirben 14 years ago.
CVS changes that cause problem

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by SF/ceztko

Attachment: i4-scummvm.png added

Indy 4 - scummvm

Changed 14 years ago by SF/ceztko

Attachment: i4-UAE.png added

Indy 4 - UAE

comment:1 Changed 14 years ago by SF/ceztko

( Forgotten :-)

Scummvm version: 8.0CVS 15/09/2005
Language: Italian
Version: Amiga floppy
Platform: Linux, every compiler

comment:2 Changed 14 years ago by fingolfin

Summary: INDY 4 Amiga: Palette problem during Sophia's presentationFOA/Amiga: Palette problem during Sophia's presentation

Changed 14 years ago by Kirben

Attachment: diff.txt added

CVS changes that cause problem

comment:3 Changed 14 years ago by Kirben

This is a regression, I have attached a diff of CVS changes
that cause this problem to occur.

comment:4 Changed 14 years ago by Kirben

Status: newclosed

comment:5 Changed 14 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Summary: FOA/Amiga: Palette problem during Sophia's presentationFOA/Amiga: Palette problem (Regression)

comment:6 Changed 14 years ago by Kirben

The palette adjustment for 32 color Amiga games uses
overflow (ie 256 should overflow to 0) to get the correct palette
in this location. The issue is fixed in ScummVM CVS.

Note: See TracTickets for help on using tickets.