Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2194 closed defect (fixed)

SKY: Missing sound effects in floppy intro

Reported by: SF/quietust Owned by: eriktorbjorn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Shortly after the "I'm picking up a JAMMING signal,
sir!" "Switch to OVER-RIDE, you MORON!" "Too LATE!!"
cockpit conversation and the helicopter flying off the
right side of the screen, the screen fades out and the
'chopper' sound effect immediately goes silent. After
the screen fades back in, the helicopter then proceeds
to crash into the ground in complete silence. The
'chopper' sound effect should NOT be cut off during the
fade-out and there should be an additional sound effect
as it crashes.

This appears to be a rather old regression, as it
behaves correctly in ScummVM 0.5.0 (the first version
that supported SKY) and 0.5.1 but incorrectly in 0.6.0
and all subsequent versions. It certainly shows how
often I play Beneath a Steel Sky...

Ticket imported from: #1288081. Ticket imported from: bugs/2194.

Change History (3)

comment:1 Changed 14 years ago by eriktorbjorn

Owner: set to eriktorbjorn
Status: newclosed

comment:2 Changed 14 years ago by eriktorbjorn

Fixed in CVS. The effects were being played, but at volume
256. The volume parameter to playRaw() is a byte, so the
value overflowed.

comment:3 Changed 14 years ago by eriktorbjorn

Resolution: fixed
Note: See TracTickets for help on using tickets.