Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2186 closed defect (invalid)

DIG: NOT playable to the end on Mac

Reported by: SF/drdoe Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: The Dig

Description

Details: This has been reported on the help forum (here: http://
sourceforge.net/forum/forum.php?
thread_id=1346035&forum_id=115757 ), but I haven't found a bug
report. Here's the description of the problem:
Having gone through much of the game, you get to a point where
you're supposed to step onto a crypt (platform) that will descend with
your character on board. However, when clicking the appropriate
spot on the front of the crypt, your character gives the same speech
he would give if you'd chosen the "examine" tool and clicked the
crypt - he does not step onto the crypt.
I've looked through several walkthroughs, all of them suggesting that
this is a bug.
Bug persists independant of platform flags (default, amiga, atari..
etc)

scummVM version: 0.8.0 (latest mac snapshot)
Game language: English
Version of game: Talkie
Platform: Run on Mac OS X (10.3.9) with above mentioned CVS
snapshot - don't know what platform the game files are from.

Try it yourself with the saved game I've attached

Ticket imported from: #1283904. Ticket imported from: bugs/2186.

Attachments (1)

dig.s18 (30.2 KB ) - added by SF/drdoe 14 years ago.
save game at the place where the bug occurs

Download all attachments as: .zip

Change History (6)

by SF/drdoe, 14 years ago

Attachment: dig.s18 added

save game at the place where the bug occurs

comment:1 by fingolfin, 14 years ago

This "issue" has been reported several times already. So far in every
single case it turned out to be a mistake by the player / incomplete walk
throughs, not a bug in ScummVM... Oh well, maybe this one is a real
bug for the first time, we'll see :-)

For reference:
<https://sourceforge.net/tracker/?
group_id=37116&atid=418820&func=detail&aid=760098>
<https://sourceforge.net/tracker/?
group_id=37116&atid=418820&func=detail&aid=923484>
<https://sourceforge.net/tracker/?
group_id=37116&atid=418820&func=detail&aid=1204551>

comment:2 by SF/drdoe, 14 years ago

weird - I searched the bug tracker and couldn't find it listed anywhere...
strange thing is, I may have found something else while trying to play the
dig from the beginning in 0.8.0:
You have to set set a trap at some point to catch an animal. Then you
have to "play sheep-dog" to get it into the trap. But the animals never do
go in, and the don't seem to respons to what my character is doing. They
just do one of two routines every time. What they do depends on what hole
in the wall they came out of...

oh, well, that's probably just me again.

comment:3 by eriktorbjorn, 14 years ago

If you're still having trouble with the slab, Boston needs
to find out more about the crypt first. Try the map room.

comment:4 by Kirben, 14 years ago

For the animal trap, just approach the animal from the
opposite side, to force it into the trap.

Closing as invalid, as this is clearly another case of a poor
walk through.

comment:5 by Kirben, 14 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.