Opened 14 years ago

Closed 14 years ago

#2185 closed defect (fixed)

ITE: Animation freezes (regression)

Reported by: SF/simsaw Owned by: SF/h00ligan
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

In ITE at two places I have animation bugs. The first
is when falling into the water of the labyrinth. Rif
doesn't swim to the other side as it should be, but he
reappears suddenly on the other side and the water
stops its animation near the end of this scene.

The second place is when chota falls down the water.
The animation of the water stops.

In earlier versions those things didn't happen. It
worked with the Daily snapshot from 17th August 2005.
I hope I am correct that it last worked before fixing
the difficulty that you couldn't leave screen when you
entered mine with Okk and Eah, because they were
blocking the exit.
I could look which versions of the files it was that
didn't have this bug (hope I still got them).

I've noticed this bug with German CD Talkie and with
English floppy disk version.

Ticket imported from: #1283707. Ticket imported from: bugs/2185.

Change History (4)

comment:1 by sev-, 14 years ago

Owner: set to sev-
Summary: ITE: Recent animation bugITE: Animation freezes (regression)

comment:2 by eriktorbjorn, 14 years ago

It seems to have been introduced by this change:
http://cvs.sourceforge.net/viewcvs.py/scummvm/scummvm/saga/animation.cpp?r1=1.54&r2=1.55

The change was made to "fix bug #1254000 ITE: Actors
duplicated at chasm scene". Unfortunately, in addition to
this bug it also seems to have caused bug #1298659.

comment:3 by sev-, 14 years ago

Component: Engine: SAGA
Game: Inherit the Earth
Owner: changed from sev- to SF/h00ligan
Resolution: fixed
Status: newclosed

comment:4 by sev-, 14 years ago

This has been fixed couple days by Andrew. Closing.

Note: See TracTickets for help on using tickets.